WH6 DKX、MACD预警公式

05-25 18:25发布

麻烦编个WH6公式预警 谢谢!

当DKX形成金叉后,价格回踩到DKX(碰到白线即可,不用收盘价),且MACD为红柱状态,发出买入信号

当DKX形成死叉后,价格回踩到DKX(碰到白线即可,不用收盘价),且MACD为绿柱状态,发出卖出信号

在预警位置加上“多”“空”字和声音提示(用不同的声音做提示)

麻烦编个WH6公式预警 谢谢!

当DKX形成金叉后,价格回踩到DKX(碰到白线即可,不用收盘价),且MACD为红柱状态,发出买入信号

当DKX形成死叉后,价格回踩到DKX(碰到白线即可,不用收盘价),且MACD为绿柱状态,发出卖出信号

在预警位置加上“多”“空”字和声音提示(用不同的声音做提示)

付费偷看设置
发送
1条回答
文华解答
1楼 · 05-25 18:59.采纳回答
参考:

DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA),COLORSTICK;
A:=(3*C+L+O+H)/6;//3倍收盘价与最高价、最低价、开盘价之和的均值。
B:(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;
//对A值做加权均值计算。
D:MA(B,10);//对B值做10周期平均计算。
DRAWTEXT(B>D&&CROSS(H,B)&&MACD>0,H,'多');
DRAWTEXT(B
B>D&&CROSS(H,B)&&MACD>0,SOUND('A');
B

一周热门 更多>