[求助]老师帮忙写个指标

05-25 18:06发布

前一根k线收盘价小于5日均线,当前k线收盘价大于5日均线,则在当前k线下方画一个红色小圆点(类似SAR指标的小圆点),

反之,前一根大于5日均线,当前根小于5日均线,则在当前根上方画一个蓝色小圆点。

前一根k线收盘价小于5日均线,当前k线收盘价大于5日均线,则在当前k线下方画一个红色小圆点(类似SAR指标的小圆点),
反之,前一根大于5日均线,当前根小于5日均线,则在当前根上方画一个蓝色小圆点。
付费偷看设置
发送
9条回答
文华解答
2楼-- · 05-25 19:21
参考:


MA5:MA(C,5);
IF(REF(CMA5,L,NULL),CIRCLEDOT,COLORRED;
IF(REF(C>MA5,1)&&C

3楼-- · 05-25 19:40
谢谢老师,我想调整一下,红点的位置为当前k线和上一根k线的最高价,绿点的位置为当前根和上一根的最低价,麻烦老师帮忙再改下
文华解答
4楼-- · 05-25 20:01
参考:

MA5:MA(C,5);
IF(REF(CMA5,HHV(H,2),NULL),CIRCLEDOT,COLORRED;
IF(REF(C>MA5,1)&&C

5楼-- · 05-25 20:21
谢谢老师,我想把这些点用黄线连起来,应该怎么写
文华解答
6楼-- · 05-25 20:40
参考:

MA5:=MA(C,5);
IF(REF(CMA5,HHV(H,2),NULL),CIRCLEDOT,COLORRED;
IF(REF(C>MA5,1)&&C

POLYLINE1(REF(CMA5||REF(C>MA5,1)&&CMA5,HHV(H,2),LLV(L,2))),COLORYELLOW;
7楼-- · 05-25 21:00
上面写反了,我调整了下

MA5:=MA(C,5);
IF(REF(C<=MA5,1)&&C>MA5,LLV(L,2),NULL),CIRCLEDOT,COLORRED;
IF(REF(C>MA5,1)&&C<=MA5,HHV(H,2),NULL),CIRCLEDOT,COLORBLUE;

POLYLINE1(REF(C<=MA5,1)&&C>MA5||REF(C>MA5,1)&&C<=MA5,IF(REF(C<=MA5,1)&&C>MA5,LLV(L,2),HHV(H,2))),COLORYELLOW;

老师,现在的圆点取的是当前和前一根k线的极值,我想修改为 当前k线到前一个圆点k线之间的k线的极值,麻烦老师修改下


一周热门 更多>