均线指标,烦请协助编辑

05-09 18:00发布

麻烦做两个指标提示(要文华七云端公式预警的格式):

1、价格从下向上穿过20日均线,在该K线下方提示“多”,反之提示"空“,同时该K线变为黄色
2、10日均线从下向上穿过20日均线形成金叉在该K线下方提示”多“,反之提示”空“,同时该K线变为黄色

麻烦做两个指标提示(要文华七云端公式预警的格式):
1、价格从下向上穿过20日均线,在该K线下方提示“多”,反之提示"空“,同时该K线变为黄色
2、10日均线从下向上穿过20日均线形成金叉在该K线下方提示”多“,反之提示”空“,同时该K线变为黄色
付费偷看设置
发送
8条回答
文华解答
2楼-- · 05-09 19:00
参考:

MA10:MA(C,10);
MA20:MA(C,20);
DRAWCOLORKLINE( CROSS(C,MA20)||CROSSDOWN(C,MA20),COLORYELLOW,0);
DRAWTEXT(CROSS(C,MA20),H,'多');
DRAWTEXT(CROSSDOWN(C,MA20),H,'空');
DRAWCOLORKLINE( CROSS(MA10,MA20)||CROSSDOWN(MA10,MA20),COLORYELLOW,0);
DRAWTEXT(CROSS(MA10,MA20),H,'多');
DRAWTEXT(CROSSDOWN(MA10,MA20),H,'空');
CROSS(C,MA20),NOTICE;
CROSSDOWN(C,MA20),NOTICE;
CROSS(MA10,MA20),NOTICE;
CROSSDOWN(MA10,MA20),NOTICE;
不悔用文华
3楼-- · 05-09 19:21
老师麻烦给改下,”多“的提示在K线的下方,然后提示”多"的那个K线能显示空心的黄色边框吗?如果可以麻烦一并修改,谢谢
文华解答
4楼-- · 05-09 19:40
参考:

MA10:MA(C,10);
MA20:MA(C,20);
DRAWCOLORKLINE( CROSS(C,MA20),COLORYELLOW,0);
DRAWCOLORKLINE( CROSSDOWN(C,MA20),COLORYELLOW,1);
DRAWTEXT(CROSS(C,MA20),H,'多');
DRAWTEXT(CROSSDOWN(C,MA20),L,'空'),VALIGN0;
DRAWCOLORKLINE( CROSS(MA10,MA20),COLORYELLOW,0);
DRAWCOLORKLINE( CROSSDOWN(MA10,MA20),COLORYELLOW,1);
DRAWTEXT(CROSS(MA10,MA20),H,'多');
DRAWTEXT(CROSSDOWN(MA10,MA20),L,'空'),VALIGN0;
CROSS(C,MA20),NOTICE;
CROSSDOWN(C,MA20),NOTICE;
CROSS(MA10,MA20),NOTICE;
CROSSDOWN(MA10,MA20),NOTICE;
不悔用文华
5楼-- · 05-09 20:00
老师,这个提示反了,我的意思是,提示“多”的字显示在K线的下方(同时K线是空心黄色边框显示),提示‘空"的字显示在K线的上方(同时K线是实心黄色显示),麻烦在帮忙改下,谢谢
文华解答
6楼-- · 05-09 20:20
参考:


MA10:MA(C,10);
MA20:MA(C,20);
DRAWCOLORKLINE( CROSS(C,MA20),COLORYELLOW,0);
DRAWCOLORKLINE( CROSSDOWN(C,MA20),COLORYELLOW,1);
DRAWTEXT(CROSS(C,MA20),L,'多'),VALIGN0;
DRAWTEXT(CROSSDOWN(C,MA20),H,'空');
DRAWCOLORKLINE( CROSS(MA10,MA20),COLORYELLOW,1);
DRAWCOLORKLINE( CROSSDOWN(MA10,MA20),COLORYELLOW,0);
DRAWTEXT(CROSS(MA10,MA20),L,'多'),VALIGN0;
DRAWTEXT(CROSSDOWN(MA10,MA20),H,'空');
CROSS(C,MA20),NOTICE;
CROSSDOWN(C,MA20),NOTICE;
CROSS(MA10,MA20),NOTICE;
CROSSDOWN(MA10,MA20),NOTICE;
不悔用文华
7楼-- · 05-09 20:41
老师,10日均线穿20日均线的提示完全正确,但价格穿20日均线的多、空提示K线的颜色显示是相反的,还得麻烦老师修改,谢谢

一周热门 更多>

相关问答