修改K线指标

05-01 13:53发布

修改K线。
HH1:=IFELSE(H LL1:=IFELSE(L>REF(L,1)&&REF(L,1)>REF(L,2),REF(L,2),0);
HH2:=VALUEWHEN(HH1>0,HH1);
LL2:=VALUEWHEN(LL1>0,LL1);
K1:=IFELSE(CLOSE>HH2,-3,IFELSE(CLOSE K2:=VALUEWHEN(K1<>0,K1);
G:=IFELSE(K2=1,HH2,LL2);
G1:=VALUEWHEN(ISLASTBAR,G);
DRAWNUMBER(L>0,G1,G1,0,COLORCYAN);
W1:=K2;
W2:=OPEN-CLOSE;
HT:=IFELSE(OPEN>CLOSE,OPEN,CLOSE);
LT:=IFELSE(OPEN DRAWLINE(W1=1,HIGH,W1=1,HT,COLORCYAN);
DRAWLINE(W1=1,LOW,W1=1,LT,COLORCYAN);
DRAWLINE(W1=-3,HIGH,W1=-3,HT,COLORRED);
DRAWLINE(W1=-3,LOW,W1=-3,LT,COLORRED);
STICKLINE(W1>0,OPEN,CLOSE,COLORCYAN,1);
STICKLINE(W1<=0,OPEN,CLOSE,COLORRED,1);
STICKLINE(W2>0&&W1<=0,OPEN,CLOSE,COLORRED,0);
STICKLINE(W2>0&&W1>0,OPEN,CLOSE,COLORCYAN,0);
//DRAWLINE(W1=1&&REF(W1,1)=1,G,W1=1&&REF(W1,1)=1,REF(G,1),COLORGREEN);
//DRAWLINE(W1=-3&&REF(W1,1)=-3,G,W1=-3&&REF(W1,1)=-3,REF(G,1),COLORYELL OW);
//DRAWSL(K2=1,G,0,1,0,COLORGREEN);
//DRAWSL(K2=-3,G,0,1,0,COLORYELLOW);
k线变为红色之后5根K线内,最新价回调到第一根红k线最低位的80%时显示太阳。变为绿色K线时反之,反弹到最高位80%时显示月亮。

修改K线。
HH1:=IFELSE(H LL1:=IFELSE(L>REF(L,1)&&REF(L,1)>REF(L,2),REF(L,2),0);
HH2:=VALUEWHEN(HH1>0,HH1);
LL2:=VALUEWHEN(LL1>0,LL1);
K1:=IFELSE(CLOSE>HH2,-3,IFELSE(CLOSE K2:=VALUEWHEN(K1<>0,K1);
G:=IFELSE(K2=1,HH2,LL2);
G1:=VALUEWHEN(ISLASTBAR,G);
DRAWNUMBER(L>0,G1,G1,0,COLORCYAN);
W1:=K2;
W2:=OPEN-CLOSE;
HT:=IFELSE(OPEN>CLOSE,OPEN,CLOSE);
LT:=IFELSE(OPEN DRAWLINE(W1=1,HIGH,W1=1,HT,COLORCYAN);
DRAWLINE(W1=1,LOW,W1=1,LT,COLORCYAN);
DRAWLINE(W1=-3,HIGH,W1=-3,HT,COLORRED);
DRAWLINE(W1=-3,LOW,W1=-3,LT,COLORRED);
STICKLINE(W1>0,OPEN,CLOSE,COLORCYAN,1);
STICKLINE(W1<=0,OPEN,CLOSE,COLORRED,1);
STICKLINE(W2>0&&W1<=0,OPEN,CLOSE,COLORRED,0);
STICKLINE(W2>0&&W1>0,OPEN,CLOSE,COLORCYAN,0);
//DRAWLINE(W1=1&&REF(W1,1)=1,G,W1=1&&REF(W1,1)=1,REF(G,1),COLORGREEN);
//DRAWLINE(W1=-3&&REF(W1,1)=-3,G,W1=-3&&REF(W1,1)=-3,REF(G,1),COLORYELL OW);
//DRAWSL(K2=1,G,0,1,0,COLORGREEN);
//DRAWSL(K2=-3,G,0,1,0,COLORYELLOW);
k线变为红色之后5根K线内,最新价回调到第一根红k线最低位的80%时显示太阳。变为绿色K线时反之,反弹到最高位80%时显示月亮。
付费偷看设置
发送
9条回答
文华解答
2楼-- · 05-01 14:52
参考:

HH1:=IFELSE(H
LL1:=IFELSE(L>REF(L,1)&&REF(L,1)>REF(L,2),REF(L,2),0);
HH2:=VALUEWHEN(HH1>0,HH1);
LL2:=VALUEWHEN(LL1>0,LL1);
K1:=IFELSE(CLOSE>HH2,-3,IFELSE(CLOSE
K2:=VALUEWHEN(K1<>0,K1);
G:=IFELSE(K2=1,HH2,LL2);
G1:=VALUEWHEN(ISLASTBAR,G);
DRAWNUMBER(L>0,G1,G1,0,COLORCYAN);
W1:=K2;
W2:=OPEN-CLOSE;
HT:=IFELSE(OPEN>CLOSE,OPEN,CLOSE);
LT:=IFELSE(OPEN
DRAWLINE(W1=1,HIGH,W1=1,HT,COLORCYAN);
DRAWLINE(W1=1,LOW,W1=1,LT,COLORCYAN);
DRAWLINE(W1=-3,HIGH,W1=-3,HT,COLORRED);
DRAWLINE(W1=-3,LOW,W1=-3,LT,COLORRED);
STICKLINE(W1>0,OPEN,CLOSE,COLORCYAN,1);
STICKLINE(W1<=0,OPEN,CLOSE,COLORRED,1);
STICKLINE(W2>0&&W1<=0,OPEN,CLOSE,COLORRED,0);
STICKLINE(W2>0&&W1>0,OPEN,CLOSE,COLORCYAN,0);
//DRAWLINE(W1=1&&REF(W1,1)=1,G,W1=1&&REF(W1,1)=1,REF(G,1),COLORGREEN);
//DRAWLINE(W1=-3&&REF(W1,1)=-3,G,W1=-3&&REF(W1,1)=-3,REF(G,1),COLORYELL OW);
//DRAWSL(K2=1,G,0,1,0,COLORGREEN);
//DRAWSL(K2=-3,G,0,1,0,COLORYELLOW);
A:=SUMBARS(CROSS(W1=-3,0.5),1)<5&&W1=-3&&C
DRAWICON(A,H,92);
B:=SUMBARS(CROSS(W1=1,0.5),1)<5&&W1=1&&C>VALUEWHEN(CROSS(W1=1,0.5),H)*0.8;
DRAWICON(B,H,91);

天涯爱文华
3楼-- · 05-01 15:11
怎没有显示太阳月亮
天涯爱文华
4楼-- · 05-01 15:32
Wn上用
文华解答
5楼-- · 05-01 15:51
满足条件会标记对应图标的,不显示说明不满足。您可以适当调整比例看下:

A:=SUMBARS(CROSS(W1=-3,0.5),1)<5&&W1=-3&&C0.8;
DRAWICON(A,H,92);
B:=SUMBARS(CROSS(W1=1,0.5),1)<5&&W1=1&&C>VALUEWHEN(CROSS(W1=1,0.5),H)*0.8;
DRAWICON(B,H,91);
天涯爱文华
6楼-- · 05-01 16:12
不显示图标
天涯爱文华
7楼-- · 05-01 16:32
比例可改≥80%或≤80%试试