几个代码请帮着核对修改下,关于k线形态,均线。

05-01 13:38发布

几个代码请您帮我核对下


将用来组合预警或选股,请您直接修改,修改部分烦您用绿字,谢谢:)

1、在特定的时间里有出现持仓量增减x的情况预警
X:=8;
A:=OPI>REF(OPI,1)*(1+X/100)&&HISEXPDAYS=145000&&CURRENTTIME<=150000;
B:=OPI=145000&&CURRENTTIME<=150000;
A,NOTICE;
B,NOTICE;


2、最高最低价偏离EMA60符合某个数值:
X:=12;
EMA60:EMA(C,60);
A:=(H-EMA60)/EMA60*100;
A>=X,NOTICE;
A<=-X,NOTICE;
3、连续收涨(收盘价比)九阴或九阳,允许其中某一根可以是开盘和收盘价相比收阴收阳
CON1:=COUNT(C>REF(C,1),9)>=8 && IF(EXIST(NOT(C>REF(C,1)),9),VALUEWHEN(NOT(C>REF(C,1)),ISUP),1);
CON2:=COUNT(C=8 && IF(EXIST(NOT(C

DRAWICON(CON1,L,4),VALIGN0;
DRAWICON(CON2,H,5),VALIGN2;
CON1||CON2,NOTICE;

4、连续几个周期收阳收阴或收涨收跌

EVERY(C>REF(C,1),4);//判断连续4天上涨
EVERY(C

EVERY(CLOSE>OPEN,4),NOTICE;//对连续四日收阳的股票预警。
EVERY(CLOSE

5、连续几个周期收涨且偏离值符合某个数值
请补充下,连续几个周期收跌
CON1:=COUNT(C>REF(C,1),9)>=9;

X:=12;
EMA60:EMA(C,60);
A:=(H-EMA60)/EMA60*100;
A>=X,NOTICE;
A<=-X,NOTICE;

6、价格来到EMA13和EMA22之间:
请补充:价格在N到M日(比如五到十日来),首次来到EMA13和EMA22之间,且此时EMA13,EMA22,EMA60呈多头排列如何写
请补充:价格在N到M日(比如五到十日来),首次来到EMA13和EMA22之间,且此时EMA13,EMA22,EMA60呈空头排列如何写
EMA13:EMA(C,13);//
EMA22:EMA(C,22);
CMIN(EMA13,EMA22),NOTICE;

7、连续小阳收涨或收跌,涨幅加起来不超过x%或跌幅加起来不超过y%
ZF:=(C-REF(C,1))/REF(C,1)*100;

CON3:=CREF(C,1),4);//连续小阳或大阳,小阴或大阴
CON4:=C>H1 && EVERY(ABS(ZF)<=3&&C

8、请问ISUP&&C-REF(C,1)>=REF(C,1)*0.02;和ISDOWN&&REF(C,1)-C<=REF(C,1)*0.02;表达的是涨跌幅吗?和ZF:=(C-REF(C,1))/REF(C,1)*100;的表达有什么区别?

9、另外,如果C-REF(C,1)>=REF(C,1)表示的就是收涨,那么ISUP&&这部分是不是多余的?

几个代码请您帮我核对下

将用来组合预警或选股,请您直接修改,修改部分烦您用绿字,谢谢:)

1、在特定的时间里有出现持仓量增减x的情况预警
X:=8;
A:=OPI>REF(OPI,1)*(1+X/100)&&HISEXPDAYS=145000&&CURRENTTIME<=150000;
B:=OPI=145000&&CURRENTTIME<=150000;
A,NOTICE;
B,NOTICE;


2、最高最低价偏离EMA60符合某个数值:
X:=12;
EMA60:EMA(C,60);
A:=(H-EMA60)/EMA60*100;
A>=X,NOTICE;
A<=-X,NOTICE;
3、连续收涨(收盘价比)九阴或九阳,允许其中某一根可以是开盘和收盘价相比收阴收阳
CON1:=COUNT(C>REF(C,1),9)>=8 && IF(EXIST(NOT(C>REF(C,1)),9),VALUEWHEN(NOT(C>REF(C,1)),ISUP),1);
CON2:=COUNT(C=8 && IF(EXIST(NOT(C

DRAWICON(CON1,L,4),VALIGN0;
DRAWICON(CON2,H,5),VALIGN2;
CON1||CON2,NOTICE;

4、连续几个周期收阳收阴或收涨收跌

EVERY(C>REF(C,1),4);//判断连续4天上涨
EVERY(C

EVERY(CLOSE>OPEN,4),NOTICE;//对连续四日收阳的股票预警。
EVERY(CLOSE

5、连续几个周期收涨且偏离值符合某个数值
请补充下,连续几个周期收跌
CON1:=COUNT(C>REF(C,1),9)>=9;

X:=12;
EMA60:EMA(C,60);
A:=(H-EMA60)/EMA60*100;
A>=X,NOTICE;
A<=-X,NOTICE;

6、价格来到EMA13和EMA22之间:
请补充:价格在N到M日(比如五到十日来),首次来到EMA13和EMA22之间,且此时EMA13,EMA22,EMA60呈多头排列如何写
请补充:价格在N到M日(比如五到十日来),首次来到EMA13和EMA22之间,且此时EMA13,EMA22,EMA60呈空头排列如何写
EMA13:EMA(C,13);//
EMA22:EMA(C,22);
CMIN(EMA13,EMA22),NOTICE;

7、连续小阳收涨或收跌,涨幅加起来不超过x%或跌幅加起来不超过y%
ZF:=(C-REF(C,1))/REF(C,1)*100;

CON3:=CREF(C,1),4);//连续小阳或大阳,小阴或大阴
CON4:=C>H1 && EVERY(ABS(ZF)<=3&&C

8、请问ISUP&&C-REF(C,1)>=REF(C,1)*0.02;和ISDOWN&&REF(C,1)-C<=REF(C,1)*0.02;表达的是涨跌幅吗?和ZF:=(C-REF(C,1))/REF(C,1)*100;的表达有什么区别?

9、另外,如果C-REF(C,1)>=REF(C,1)表示的就是收涨,那么ISUP&&这部分是不是多余的?

付费偷看设置
发送
9条回答
文华解答
2楼-- · 05-01 14:51
1,2,3,4,7编写是对的。

5
CON1:=COUNT(C>REF(C,1),9)>=9;
CON2:=COUNT(C=9;

X:=12;
EMA60:EMA(C,60);
A:=(H-EMA60)/EMA60*100;
A>=X&&CON1,NOTICE;
A<=-X&&CON2,NOTICE;

8 表达没区别就是等式的显示方式不同。

9C-REF(C,1)>=0表示涨,ISUP 表示阳线,含义不同的。

阳线时可能收盘价并不比上一根收盘价高的。

6
EMA13:EMA(C,13);//
EMA22:EMA(C,22);
EMA60:EMA(C,60);
DT:=EMA13>EMA22&&EMA22>EMA60;
KT:=EMA13
X1:=CMIN(EMA13,EMA22)&&DT;
X2:=CMIN(EMA13,EMA22)&&KT;
REF(EXIST(CROSS(X2,0.5),5),5),NOTICE;
REF(EXIST(CROSS(X1,0.5),5),5),NOTICE;
文华自动化
3楼-- · 05-01 15:11
EMA13:EMA(C,13);//
EMA22:EMA(C,22);
EMA60:EMA(C,60);
DT:=EMA13>EMA22&&EMA22>EMA60;
KT:=EMA13
X1:=CMIN(EMA13,EMA22)&&DT;
X2:=CMIN(EMA13,EMA22)&&KT;
REF(EXIST(CROSS(X2,0.5),5),5),NOTICE;
REF(EXIST(CROSS(X1,0.5),5),5),NOTICE;


谢谢您的解答

大部分看懂了,5天-10天来,第一次到达这个区域(指E13和E22之间,不管空头排列还是多头排列),这个5-10天来,第一次到达,表现在哪句代码呢
文华解答
4楼-- · 05-01 15:30
最后的预警语句就包含了,

判断之前5-10存在第一次条件满足。
文华自动化
5楼-- · 05-01 15:50
好的,明白了,感谢:)
文华自动化
6楼-- · 05-01 16:10
1、 EVERY(ABS(ZF)<=3&&C

以上这个代码为何语法判断上一直说原括号不匹配?

2、请教下,这个代码是指四根连续收阴情况,其中每根阴线幅度小于-3,这个部分要不要改为。。。<=-3 ..??

谢谢:)
文华解答
7楼-- · 05-01 16:30
1. EVERY(ABS(ZF)<=3&&C

2.不用,已经有别的条件限制了。

相关问答