修改指标的问题

05-01 13:39发布

麻烦老师把这下面的两个互相过滤共振

A:=(3*C+L+O+H)/6;
B:(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)
+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210,COLORMAGENTA;
D:MA(B,13);
DRAWTEXT(CROSS(B,D),D,'买'),COLORMAGENTA,VALIGN0,FONTSIZE26;
DRAWTEXT(CROSS(D,B),D,'卖'),COLORBLUE,VALIGN0,FONTSIZE26;
CROSS(B,D),SOUND('A');
CROSS(D,B),SOUND('B');

DIFF:EMA(CLOSE,40) - EMA(CLOSE,100),COLORBLUE,LINETHICK2;
DEA:EMA(DIFF,10),LINETHICK2;
MACD:2*(DIFF-DEA),COLORSTICK;
JC:=CROSS(DIFF,DEA);
SC:=CROSSDOWN(DIFF,DEA);
DRAWTEXT(JC,DIFF,'多'),COLORYELLOW,VALIGN0;
DRAWTEXT(SC,DEA,'空'),COLORWHITE,VALIGN2;
JC,SOUND('A');
SC,SOUND('A');

麻烦老师把这下面的两个互相过滤共振

A:=(3*C+L+O+H)/6;
B:(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)
+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210,COLORMAGENTA;
D:MA(B,13);
DRAWTEXT(CROSS(B,D),D,'买'),COLORMAGENTA,VALIGN0,FONTSIZE26;
DRAWTEXT(CROSS(D,B),D,'卖'),COLORBLUE,VALIGN0,FONTSIZE26;
CROSS(B,D),SOUND('A');
CROSS(D,B),SOUND('B');

DIFF:EMA(CLOSE,40) - EMA(CLOSE,100),COLORBLUE,LINETHICK2;
DEA:EMA(DIFF,10),LINETHICK2;
MACD:2*(DIFF-DEA),COLORSTICK;
JC:=CROSS(DIFF,DEA);
SC:=CROSSDOWN(DIFF,DEA);
DRAWTEXT(JC,DIFF,'多'),COLORYELLOW,VALIGN0;
DRAWTEXT(SC,DEA,'空'),COLORWHITE,VALIGN2;
JC,SOUND('A');
SC,SOUND('A');

付费偷看设置
发送
9条回答
文华解答
2楼-- · 05-01 14:36
参考:

A:=(3*C+L+O+H)/6;
B:(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)
+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210,COLORMAGENTA;
D:MA(B,13);
DIFF:=EMA(CLOSE,40) - EMA(CLOSE,100),COLORBLUE,LINETHICK2;
DEA:=EMA(DIFF,10),LINETHICK2;
MACD:=2*(DIFF-DEA),COLORSTICK;
JC:=CROSS(DIFF,DEA);
SC:=CROSSDOWN(DIFF,DEA);
DRAWTEXT(JC&&CROSS(B,D),DIFF,'多'),COLORYELLOW,VALIGN0;
DRAWTEXT(SC&&CROSS(D,B),DEA,'空'),COLORWHITE,VALIGN2;
CROSS(B,D)&&JC,SOUND('A');
CROSS(D,B)&&SC,SOUND('B');


天涯爱文华
3楼-- · 05-01 14:55

老师你加载看了吗?什么也没有了

天涯爱文华
4楼-- · 05-01 15:16

老师加载了,信号也没有了

文华解答
5楼-- · 05-01 15:36
是同时满足多和买进行标记,同时满足空和卖进行标记。

条件同时满足信号很少的。

如果您觉得不符合您的思路,可以说明共振的具体条件。
天涯爱文华
6楼-- · 05-01 15:56

哦哦,是我说错了,不是同一时间共振,只是上下过滤

天涯爱文华
7楼-- · 05-01 16:16
攻击线:=MA(C,4),COLORBLUE;
神奇线:EMA(C,100),COLORMAGENTA,LINETHICK4;
DIFF:=EMA(CLOSE,40) - EMA(CLOSE,100),COLORBLUE,LINETHICK2;
DEA:=EMA(DIFF,10),LINETHICK2;
MACD:=2*(DIFF-DEA),COLORSTICK;
JC:=CROSS(DIFF,DEA);
SC:=CROSSDOWN(DIFF,DEA);
AA:=BARSLAST(CROSS(攻击线,神奇线)&&DIFF>DEA||JC&&攻击线>神奇线)+1;
BB:=BARSLAST(CROSSDOWN(攻击线,神奇线)&&DIFFDRAWTEXT((CROSS(攻击线,神奇线)&&DIFF>DEA||JC&&攻击线>神奇线)&&AADRAWTEXT((CROSSDOWN(攻击线,神奇线)&&DIFFBB&&COUNT(BB,AA)=1,H,'空'),COLORWHITE,FONTSIZE26,VALIGN2;
(CROSS(攻击线,神奇线)&&DIFF>DEA||JC&&攻击线>神奇线)&&AA(CROSSDOWN(攻击线,神奇线)&&DIFFBB&&COUNT(BB,AA)=1,SOUND('A');
和上面这个的一样改,谢谢