KD MACD编写交易指标

03-26 21:28发布

3日内满足 ①KD50线下金叉(金叉形成那一刻小于50就行,做单时可以大于50),②MACD指标0轴下金叉,③成交量比前一天这3个条件做多;

3日内满足 ①KD50线上死叉(死叉形成那一刻大于50就行,做单时可以小于50),②MACD指标0轴上死叉,③成交量比前一天这3个条件做空;
麻烦老师给写个公式

3日内满足 ①KD50线下金叉(金叉形成那一刻小于50就行,做单时可以大于50),②MACD指标0轴下金叉,③成交量比前一天这3个条件做多;
3日内满足 ①KD50线上死叉(死叉形成那一刻大于50就行,做单时可以小于50),②MACD指标0轴上死叉,③成交量比前一天这3个条件做空;
麻烦老师给写个公式
付费偷看设置
发送
3条回答
文华解答
2楼-- · 03-26 22:36
参考:

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);

DIFF := EMA(CLOSE,12) - EMA(CLOSE,26),COLORGRAY;
DEA := EMA(DIFF,9),COLORGRAY;
MACD:=2*(DIFF-DEA),COLORSTICK;


CON1:=K>D && REF(K<50,BARSLAST(CROSS(K,D)));
CON2:=DIFF<0 && CROSS(DIFF,DEA);
CON3:=V>REF(V,1);

CON11:=K50,BARSLAST(CROSSDOWN(K,D)));
CON22:=DIFF>0 && CROSSDOWN(DIFF,DEA);
CON33:=V>REF(V,1);

EXIST(CON1 && CON2 && CON3,3),BPK;
EXIST(CON11 && CON22 && CON33,3),SPK;
AUTOFILTER;
天涯爱文华
3楼-- · 03-26 22:56
老师你好 是KD50线下金叉(金叉形成那一刻小于50就行,做单时可以大于50),MACD指标0轴下金叉 这2个指标金叉必须是3日内完成, 在这个期间 出现成交量大于前一日 就行
文华解答
4楼-- · 03-26 23:16
参考:

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);

DIFF := EMA(CLOSE,12) - EMA(CLOSE,26),COLORGRAY;
DEA := EMA(DIFF,9),COLORGRAY;
MACD:=2*(DIFF-DEA),COLORSTICK;


CON1:=K>D && REF(K<50,BARSLAST(CROSS(K,D)));
CON2:=DIFF<0 && CROSS(DIFF,DEA);
CON3:=V>REF(V,1);

CON11:=K50,BARSLAST(CROSSDOWN(K,D)));
CON22:=DIFF>0 && CROSSDOWN(DIFF,DEA);
CON33:=V>REF(V,1);

EXIST(CROSS(K,D) && K<50,3) && CON1 && EXIST(CON2,3) && CON3,BPK;
EXIST(CROSSDOWN(K,D) && K>50,3) && CON11 && EXIST(CON22,3) && CON33,SPK;
AUTOFILTER;