副图指标数字问题

03-26 21:42发布

副图指标的数字最多到小数点后面两位,有办法到三位吗? 如果没办法,请问两位是四舍五入的结果吗? 比如 0.041 会显示0.04 , 而0.046会显示0.05 对吗

副图指标的数字最多到小数点后面两位,有办法到三位吗?

如果没办法,请问两位是四舍五入的结果吗? 比如 0.041 会显示0.04 , 而0.046会显示0.05 对吗
付费偷看设置
发送
5条回答
文华解答
2楼-- · 03-26 22:36
可以的,调整指标源码编写最多可以实现显示6位小数,是四舍五入计算的。

以常用的KD指标为例,下面编写就是四舍五入保留3位小数,标红位置是小数位数的控制部分,参数0-6。

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
BACKGROUNDSTYLE(1);
K:SMA(RSV,3,1),PRECIS3;
D:SMA(K,3,1),PRECIS3;


文华向前进
3楼-- · 03-26 22:56
这个呢 WIDTH保留三个小数

MID:=MA(CLOSE,20);
TMP2:=STD(CLOSE,20);
TOP:=MID+2*TMP2;
BOTTOM:=MID-2*TMP2;
WIDTH:(TOP-BOTTOM)/MID;
文华解答
4楼-- · 03-26 23:15
这个变量数值比较小,可以做一下百分化处理,就是直接*100,表示上轨减下轨占中轨的百分比,

参考:

MID:=MA(CLOSE,20);
TMP2:=STD(CLOSE,20);
TOP:=MID+2*TMP2;
BOTTOM:=MID-2*TMP2;
WIDTH:(TOP-BOTTOM)/MID*100,PRECIS3;
文华向前进
5楼-- · 03-26 23:36
可以。或者有没有办法写成附属指标,以免占一个幅图指标的格子。满足WIDTH小于5%的对应K线下加一个笑脸

只在日线图中显示
文华解答
6楼-- · 03-26 23:56
参考;

MID:=MA(CLOSE,20);
TMP2:=STD(CLOSE,20);
TOP:=MID+2*TMP2;
BOTTOM:=MID-2*TMP2;
WIDTH:(TOP-BOTTOM)/MID*100,PRECIS3,NODRAW;
DRAWICON(PERIOD=8&&WIDTH<5,L,1),VALIGN0;