MACD\MA20\成交量的关系公式

03-26 21:42发布

条件:(一)MACD零轴上金叉、MA20向上(红线表示),成交量VOL用大红柱子表示,如

(二)MACD零轴上死叉、MA20向下(绿线表示),成交量VOL用紫色柱子表示,如
(三)MACD零轴下金叉、MA20向上(红线表示),成交量VOL用蓝色柱子表示,如
(四)MACD零轴下死叉、MA20向下(绿线表示),成交量VOL用大绿柱子表示,如
除了以上四种情况外,成交量全用白柱子表示。
老师辛苦了,非常感谢!

条件:(一)MACD零轴上金叉、MA20向上(红线表示),成交量VOL用大红柱子表示,如
(二)MACD零轴上死叉、MA20向下(绿线表示),成交量VOL用紫色柱子表示,如
(三)MACD零轴下金叉、MA20向上(红线表示),成交量VOL用蓝色柱子表示,如
(四)MACD零轴下死叉、MA20向下(绿线表示),成交量VOL用大绿柱子表示,如
除了以上四种情况外,成交量全用白柱子表示。
老师辛苦了,非常感谢!
付费偷看设置
发送
6条回答
文华解答
2楼-- · 03-26 22:34
均线变色参考:

MA20:MA(C,20);
DRAWCOLORLINE(MA20>REF(MA20,1),MA20,COLORRED,COLORGREEN);

成交量变色参考:


MA20:=MA(C,20);
DIFF : EMA(CLOSE,12) - EMA(CLOSE,26);
DEA : EMA(DIFF,9);
MACD:2*(DIFF-DEA),COLORSTICK;
JC:=CROSS(DIFF,DEA);
SC:=CROSSDOWN(DIFF,DEA);
STICKLINE(1,0,V,COLORWHITE,0);
A1:=MACD>0&&JC&&MA20>REF(MA20,1);
STICKLINE(A1,0,V,COLORRED,0);
A2:=MACD>0&&SC&&MA20
STICKLINE(A2,0,V,COLORMAGENTA,0);
A3:=MACD<0&&JC&&MA20>REF(MA20,1);
STICKLINE(A3,0,V,COLORBLUE,0);
A4:=MACD<0&&SC&&MA20
STICKLINE(A4,0,V,COLORGREEN,0);


文华问答
3楼-- · 03-26 22:54
老师,颜色不对,基本都是白色,改改,谢谢!
文华问答
4楼-- · 03-26 23:14
老师,是我没表示清楚,应该是:
条件:(一)MACD零轴上金叉、只要MA20向上(红线表示),成交量VOL都用大红柱子表示,如
(二)MACD零轴上死叉、只要MA20向下(绿线表示),成交量VOL都用紫色柱子表示,如
(三)MACD零轴下金叉、只要MA20向上(红线表示),成交量VOL都用蓝色柱子表示,如
(四)MACD零轴下死叉、只要MA20向下(绿线表示),成交量VOL都用大绿柱子表示,如
除了以上四种情况外,成交量全用白柱子表示。
文华解答
5楼-- · 03-26 23:33
macd金叉死叉,就是一根K线,所以变色只会在金叉死叉那根K线变色。

您可以看下2楼变色的K线是否为MACD金叉和死叉。
文华问答
6楼-- · 03-26 23:53
老师,零轴上金叉后、只要MA20向上,成交量继续用大红柱状图表示而不是白色;其它条件也同样理解呀,难道没表达清楚?
文华解答
7楼-- · 03-27 00:13

MA20:=MA(C,20);
DIFF : EMA(CLOSE,12) - EMA(CLOSE,26);
DEA : EMA(DIFF,9);
MACD:2*(DIFF-DEA),COLORSTICK;
JC:=DIFF>DEA;
SC:=DIFF
STICKLINE(1,0,V,COLORWHITE,0);
A1:=MACD>0&&JC&&MA20>REF(MA20,1);
STICKLINE(A1,0,V,COLORRED,0);
A2:=MACD>0&&SC&&MA20
STICKLINE(A2,0,V,COLORMAGENTA,0);
A3:=MACD<0&&JC&&MA20>REF(MA20,1);
STICKLINE(A3,0,V,COLORBLUE,0);
A4:=MACD<0&&SC&&MA20
STICKLINE(A4,0,V,COLORGREEN,0);