[求助]修改一下高低点回撤标注

03-08 19:17发布

老师好

老师好

付费偷看设置
发送
9条回答
文华向前进
2楼-- · 03-08 20:19

另外再把这个规则做成选股公式,参数可调型的选股公式,

参数可选项有

所有市场(比如A股 期货 板块指数 合约指数)

时间(比如在月线 周线 日线 1小时 )

文华向前进
3楼-- · 03-08 20:38
另外再把这个规则做成选股公式,参数可调型的选股公式,用来选出出现笑脸的选股公式

参数可选项有

所有市场(比如A股 期货 股票板块指数 文华商品板块指数 期货合约指数)

时间(比如在月线 周线 日线 1小时 )

文华解答
4楼-- · 03-08 20:58
参考:

HY:=STKTYPE=7;//国内期货
ZQA:=PERIOD=8;//日周期
TJ:=HY && ZQA;

N:=3;
GD:=H>HV(H,N) && H>REFX(HHV(H,N),N);
DD:=L
//大于小于前后各N根K线高低价,定义为高低点


T1:=SUMBARS(GD,1)>=4 && REF(L<=LLV(L,SUMBARS(GD,1)) && CREF(H,1);
TJ&& COUNT(T1,SUMBARS(GD,1))=1 && T1,ICON(1,'ICO1');


T2:=SUMBARS(DD,1)>=4 && REF(H>=HHV(H,SUMBARS(DD,1)) && C>VALUEWHEN(DD,C),1) && L>REF(L,1);
TJ&& COUNT(T2,SUMBARS(DD,1))=1 && T2,ICON(1,'ICO2');

MA20:MA(C,20);

//------9转指标
A1:=C>REF(C,4);
NT:=BARSLASTCOUNT(A1);
TJ11:=9;
TJ13:=ISLASTBAR AND BETWEEN(NT,5,8);
AY:=(BACKSET(TJ11>0,9) OR BACKSET(TJ13>0,NT))*NT;
MM:=BACKSET(NT=9,9);
DRAWNUMBER(MM=1&&AY>0,H,NT,0,COLORYELLOW);
NX:=BACKSET(ISLASTBAR,NT);
DRAWNUMBER(NX&&REFX1(NT<9,100),H,NT,0,COLORYELLOW);
DRAWICON(NT=9,H+2,'ICO9'),COLORGREEN;

B1:=C
NT0:=BARSLASTCOUNT(B1);
TJ21:=NT0=9 ;
NN:=BACKSET(NT0=9,9);
TJ23:=ISLASTBAR AND BETWEEN(NT0,5,8);
AY1:=(BACKSET(TJ21>0,9) OR BACKSET(TJ23>0,NT0))*NT0;
DRAWNUMBER(NN=1&&AY1>0,L,NT0,0,COLORFF00FF),VALIGN0;
ND:=BACKSET(ISLASTBAR,NT0);
DRAWNUMBER(ND&&REFX1(NT0<9,100),L,NT0,0,COLORFF00FF),VALIGN0;
DRAWICON(NT0=9,L-2,'ICO112'),COLORGREEN;


文华向前进
5楼-- · 03-08 21:19

笑脸出现的地方不对啊

文华向前进
6楼-- · 03-08 21:38

文华向前进
7楼-- · 03-08 21:59