请老师帮忙改下指标,谢谢。

03-08 19:22发布

HHH:=VALUEWHEN(DAYBARPOS=1,H);

LLL:=VALUEWHEN(DAYBARPOS=1,L);

C>=HHH&&BARSLAST(TIME=0900)>15&&DAYBARPOS>=2&&COUNTSIG(BK,DAYBARPOS)=0&&ISLASTKLINE=0,BK;//买开
C<=LLL&&BARSLAST(TIME=0900)>15&&DAYBARPOS>=2&&COUNTSIG(SP,DAYBARPOS)=0&&ISLASTKLINE=0,SK;//卖开


C<=LLL&&DAYBARPOS>=2||C>=(BKPRICE+20)>0&&DAYBARPOS>=2,BP;
C>=HHH&&DAYBARPOS>=2||C<=(SKPRICE-20)>0&&DAYBARPOS>=2,SP;

MULTSIG(0,0,1,0);

//收盘前平仓
CLOSEMINUTE<=1,CLOSEOUT;
SETSIGPRICETYPE(CLOSEOUT,LIMIT_ORDER);
AUTOFILTER;

//--------------------------


请老师帮忙看看,老是提示:CLOSESEC/CLOSESECEVERY/CLOSEMINUTE/CLOSEMINUTEEVERY只支持收盘价模型,不能再写CHECKSIG/CHECKSIG_MIN、MULTSIG/MULTSIG_MIN/PANZHONG_MIN函数
我的目的就是想用指令价开仓和平仓。

HHH:=VALUEWHEN(DAYBARPOS=1,H);
LLL:=VALUEWHEN(DAYBARPOS=1,L);

C>=HHH&&BARSLAST(TIME=0900)>15&&DAYBARPOS>=2&&COUNTSIG(BK,DAYBARPOS)=0&&ISLASTKLINE=0,BK;//买开
C<=LLL&&BARSLAST(TIME=0900)>15&&DAYBARPOS>=2&&COUNTSIG(SP,DAYBARPOS)=0&&ISLASTKLINE=0,SK;//卖开


C<=LLL&&DAYBARPOS>=2||C>=(BKPRICE+20)>0&&DAYBARPOS>=2,BP;
C>=HHH&&DAYBARPOS>=2||C<=(SKPRICE-20)>0&&DAYBARPOS>=2,SP;

MULTSIG(0,0,1,0);

//收盘前平仓
CLOSEMINUTE<=1,CLOSEOUT;
SETSIGPRICETYPE(CLOSEOUT,LIMIT_ORDER);
AUTOFILTER;

//--------------------------


请老师帮忙看看,老是提示:CLOSESEC/CLOSESECEVERY/CLOSEMINUTE/CLOSEMINUTEEVERY只支持收盘价模型,不能再写CHECKSIG/CHECKSIG_MIN、MULTSIG/MULTSIG_MIN/PANZHONG_MIN函数
我的目的就是想用指令价开仓和平仓。
付费偷看设置
发送
9条回答
文华解答
2楼-- · 03-08 20:14
参考;

HHH:=VALUEWHEN(DAYBARPOS=1,H);
LLL:=VALUEWHEN(DAYBARPOS=1,L);

C>=HHH&&BARSLAST(TIME=0900)>15&&DAYBARPOS>=2&&COUNTSIG(BK,DAYBARPOS)=0&&ISLASTKLINE=0,BK;//买开
C<=LLL&&BARSLAST(TIME=0900)>15&&DAYBARPOS>=2&&COUNTSIG(SP,DAYBARPOS)=0&&ISLASTKLINE=0,SK;//卖开


C<=LLL&&DAYBARPOS>=2||C>=(BKPRICE+20)>0&&DAYBARPOS>=2,BP;
C>=HHH&&DAYBARPOS>=2||C<=(SKPRICE-20)>0&&DAYBARPOS>=2,SP;

MULTSIG(0,0,1,0);

//收盘前平仓
CLOSEMINUTE1<=1,CLOSEOUT;
SETSIGPRICETYPE(CLOSEOUT,LIMIT_ORDER);
AUTOFILTER;

不悔用文华
3楼-- · 03-08 20:34
开、平仓每天只执行一次怎么设置呀?
文华解答
4楼-- · 03-08 20:54
参考;

HHH:=VALUEWHEN(DAYBARPOS=1,H);
LLL:=VALUEWHEN(DAYBARPOS=1,L);
AA:COUNTSIG(BK,DAYBARPOS)+COUNTSIG(SK,DAYBARPOS),NODRAW;
C>=HHH&&BARSLAST(TIME=0900)>15&&DAYBARPOS>=2&&COUNTSIG(BK,DAYBARPOS)=0&&ISLASTKLINE=0&&AA=0,BK;//买开
C<=LLL&&BARSLAST(TIME=0900)>15&&DAYBARPOS>=2&&COUNTSIG(SP,DAYBARPOS)=0&&ISLASTKLINE=0&&AA=0,SK;//卖开


C<=LLL&&DAYBARPOS>=2||C>=(BKPRICE+20)>0&&DAYBARPOS>=2,BP;
C>=HHH&&DAYBARPOS>=2||C<=(SKPRICE-20)>0&&DAYBARPOS>=2,SP;

MULTSIG(0,0,1,0);

//收盘前平仓
CLOSEMINUTE1<=1,CLOSEOUT;
SETSIGPRICETYPE(CLOSEOUT,LIMIT_ORDER);
AUTOFILTER;

不悔用文华
5楼-- · 03-08 21:13
老师,这个模型的卖点始终不对,能否帮我改改。
我的思路是
1.突破当前周期第1根K线的最高价做多;跌破当前周期第1根K线的最低价做空。
2.买开止赢,大于买入价的N跳止赢;卖开止赢,小于卖开价的N跳止赢。
3.买开止损,小于第1根K线的最低价止损;卖开止损,大于第1根K线的最低价止损。
----------
通过上述的代码测试了一下,开仓点没问题了。但是卖出点始终不对。麻烦老师看看那里出错了。谢谢
文华解答
6楼-- · 03-08 21:33
参考:

HHH:=VALUEWHEN(DAYBARPOS=1,H);
LLL:=VALUEWHEN(DAYBARPOS=1,L);
AA:COUNTSIG(BK,DAYBARPOS)+COUNTSIG(SK,DAYBARPOS),NODRAW;
C>=HHH&&DAYBARPOS>=2&&COUNTSIG(BK,DAYBARPOS)=0&&ISLASTKLINE=0&&AA=0,BK;//买开
C<=LLL&&DAYBARPOS>=2&&COUNTSIG(SP,DAYBARPOS)=0&&ISLASTKLINE=0&&AA=0,SK;//卖开

N:20,NODRAW;
C<=LLL&&DAYBARPOS>=2||C>=(BKPRICE+N*MINPRICE)&&DAYBARPOS>=2,SP;
C>=HHH&&DAYBARPOS>=2||C<=(SKPRICE-N*MINPRICE)&&DAYBARPOS>=2,BP;

MULTSIG(0,0,1,0);

//收盘前平仓
CLOSEMINUTE1<=1,CLOSEOUT;
SETSIGPRICETYPE(CLOSEOUT,LIMIT_ORDER);
AUTOFILTER;
不悔用文华
7楼-- · 03-08 21:53
请老师帮忙改下:平仓代码错了。
------------------------

#IMPORT [MIN,3,MACD] AS VAR
3DIFF:VAR.DIFF;
3DEA:VAR.DEA;


MA1:MA(CLOSE,N1);
DIFF:EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:EMA(DIFF,9);
HHH:VALUEWHEN(DAYBARPOS=1,H);
LLL:VALUEWHEN(DAYBARPOS=1,L);
AA:COUNTSIG(BK,DAYBARPOS),NODRAW;
BB:COUNTSIG(SK,DAYBARPOS),NODRAW;
C>=HHH&&DAYBARPOS>=2&&ISLASTKLINE=0&&AA=0&&VALUEWHEN(DAYBARPOS=1,O)>MA1,BK;//买开
C<=LLL&&DAYBARPOS>=2&&ISLASTKLINE=0&&BB=0&&VALUEWHEN(DAYBARPOS=1,O)


//---老师帮我改改平仓代码,始终在一根K线开平仓,不知道我引用对没有,我引用了3分钟的MACD数据。
3DIFF<0&&3DEA<0&&DAYBARPOS>=1,BP;
3DEA>0&&3DIFF>0&&DAYBARPOS>=1,SP;
//--


MULTSIG(0,0,4,0);


//收盘前平仓
CLOSEMINUTE1<=1,CLOSEOUT;
SETSIGPRICETYPE(CLOSEOUT,LIMIT_ORDER);
AUTOFILTER;