收盘价划线,划线颜色改为黄色

03-08 19:05发布

老师楼下指标修改为收盘价划线,划线颜色改为黄色,谢谢

老师楼下指标修改为收盘价划线,划线颜色改为黄色,谢谢
付费偷看设置
发送
9条回答
文华向前进
2楼-- · 03-08 20:01
N:=2;
AA:REFX(REF(ABS(O-C)<=N,1),1),NODRAW;
DRAWSL(1,VALUEWHEN(AA,O),0,1,0,COLORRED);
DRAWNUMBER(AA,H,O,1,COLORYELLOW);

文华解答
3楼-- · 03-08 20:22
参考:

N:=2;
AA:REFX(REF(ABS(O-C)<=N,1),1),NODRAW;
DRAWSL(1,VALUEWHEN(AA,C),0,1,0,COLORYELLOW);
DRAWNUMBER(AA,H,O,1,COLORYELLOW);
文华向前进
4楼-- · 03-08 20:42
老师,楼上指标(5分钟周期)划线跨越小周期(5秒周期)显示,谢谢
文华解答
5楼-- · 03-08 21:01
参考:

VV:="MIN$5$V";
NN:=BARSLAST(VV<>REF(VV,1))+1;
SP1:=REFX(NN=1,1)||ISLASTBAR;

N:=2;

AA:SP1 && NOT(ISLASTBAR) && ABS(REF(O,NN-1)-C)<=N,NODRAW;

DRAWSL(1,VALUEWHEN(AA,C),0,1,0,COLORYELLOW);
DRAWNUMBER(AA,HHV(H,NN),O,1,COLORYELLOW);
文华向前进
6楼-- · 03-08 21:22
老师,2楼指标加载声音预警,条件成立后穿预警,不是运行途中预警,谢谢。5楼指标再做1小时K线,日线两种指标。谢谢了
文华解答
7楼-- · 03-08 21:42
//5-MIN:

VV:="MIN$5$V";
NN:=BARSLAST(VV<>REF(VV,1))+1;
SP1:=REFX(NN=1,1)||ISLASTBAR;

N:=2;

AA:SP1 && NOT(ISLASTBAR) && ABS(REF(O,NN-1)-C)<=N,NODRAW;

DRAWSL(1,VALUEWHEN(AA,C),0,1,0,COLORYELLOW);
DRAWNUMBER(AA,HHV(H,NN),O,1,COLORYELLOW);

REF(AA,1),SOUND('A');

//1-hour

VV:="HOUR$1$V";
NN:=BARSLAST(VV<>REF(VV,1))+1;
SP1:=REFX(NN=1,1)||ISLASTBAR;

N:=2;

AA:SP1 && NOT(ISLASTBAR) && ABS(REF(O,NN-1)-C)<=N,NODRAW;

DRAWSL(1,VALUEWHEN(AA,C),0,1,0,COLORYELLOW);
DRAWNUMBER(AA,HHV(H,NN),O,1,COLORYELLOW);

REF(AA,1),SOUND('A');

//1-DAY

VV:="DAY$1$V";
NN:=BARSLAST(VV<>REF(VV,1))+1;
SP1:=REFX(NN=1,1)||ISLASTBAR;

N:=2;

AA:SP1 && NOT(ISLASTBAR) && ABS(REF(O,NN-1)-C)<=N,NODRAW;

DRAWSL(1,VALUEWHEN(AA,C),0,1,0,COLORYELLOW);
DRAWNUMBER(AA,HHV(H,NN),O,1,COLORYELLOW);

REF(AA,1),SOUND('A');