[求助]能否把ASI指标改成象通达信那样有二条线的指标?

02-20 11:53发布

[求助]能否把ASI指标改成象通达信那样有二条线的指标?通达信的ASI有二条线,会产生金死叉,比较好参照,老师能否改成那样子的呢?而且通达信那个ASI是有参数可以修改的。能否与改成可以修改参数呢?

[求助]能否把ASI指标改成象通达信那样有二条线的指标?通达信的ASI有二条线,会产生金死叉,比较好参照,老师能否改成那样子的呢?而且通达信那个ASI是有参数可以修改的。能否与改成可以修改参数呢?
付费偷看设置
发送
1条回答
文华解答
1楼 · 02-20 12:31.采纳回答
通达信ASI公式是加密的我们看不到具体源码,给您在常规的ASI公式中加一条慢线,

参数是M,参考;

M:=10;
LC:=REF(CLOSE,1);
AA:=ABS(HIGH-LC);
BB:=ABS(LOW-LC);
CC:=ABS(HIGH-REF(LOW,1));
DD:=ABS(LC-REF(OPEN,1));
R:=IFELSE(AA>BB&&AA>CC,AA+BB/2+DD/4,IFELSE(BB>CC&&BB>AA,BB+AA/2+DD/4,CC+DD/4));
X:=(CLOSE-LC+(CLOSE-OPEN)/2+LC-REF(OPEN,1));
SI:=16*X/R*MAX(AA,BB);
ASI:SUM(SI,0);
ASIM:MA(ASI,M);