想在这个指标基础上,修改一下高低点定义

01-23 10:33发布

N:=3;

DING:=H>HV(H,N)&&H>REFX(HHV(H,N),N);

DI:=L
DRAWICON(DING,H,'ICO8');
DRAWICON(DI,L,'ICO9'),VALIGN0;

MA30:EMA(C,N1);


改成
顶点定义: 一个k线最高价高于前后两个K线最高价,而且随后满足任意三根的最高价低于这个根k线最低价,这个k线定义成高点;
低点定义: 一个k线最低价低于前后两个K线最低价,而且随后满足任意三根的最低价高于这个根k线最高价,这个k线定义成低点;

N:=3;
DING:=H>HV(H,N)&&H>REFX(HHV(H,N),N);

DI:=L
DRAWICON(DING,H,'ICO8');
DRAWICON(DI,L,'ICO9'),VALIGN0;

MA30:EMA(C,N1);


改成
顶点定义: 一个k线最高价高于前后两个K线最高价,而且随后满足任意三根的最高价低于这个根k线最低价,这个k线定义成高点;
低点定义: 一个k线最低价低于前后两个K线最低价,而且随后满足任意三根的最低价高于这个根k线最高价,这个k线定义成低点;
付费偷看设置
发送
5条回答
文华解答
2楼-- · 01-23 11:27
参考:

N:=2;
N1:=3;
DING:=H>HV(H,N)&&H>REFX(HHV(H,N),N) && H>REFX(HHV(H,N1),N+N1);

DI:=L
DRAWICON(DING,H,'ICO8');
DRAWICON(DI,L,'ICO9'),VALIGN0;

MA30:EMA(C,N1);

天涯爱文华
3楼-- · 01-23 11:47
希望再修改一下,比如高点1先出现,后面出现高点2,如果高点2的高点比高点1的高点还要低,就不要画高点2出来, 反之低点也是
文华解答
4楼-- · 01-23 12:06
如果高点2没有画出,高点3 是和没有画的高点2对比 还是已经画出的高点1对比?
天涯爱文华
5楼-- · 01-23 12:26
比如高点1画出来, 高点2的条件形成,然后和高点1对比;如果不成立则不画,那么后面高点3,4,5,6,7还是是和高点1对比
文华解答
6楼-- · 01-23 12:47

参考:

N:=2;
N1:=3;
DING:=H>HV(H,N)&&H>REFX(HHV(H,N),N) && H>REFX(HHV(H,N1),N+N1);

DI:=L


HH:=VALUEWHEN(DING,H);
LL:=VALUEWHEN(DI,L);

DRAWICON(DING && H>=HHV(H,BARPOS),H,'ICO8');
DRAWICON(DI && L<=LLV(L,BARPOS),L,'ICO9'),VALIGN0;

MA30:EMA(C,N1);