请老师修改DKX指标加入一个时间显示限制

01-23 10:30发布

我的要求:DKX指标加入一个时间显示限制,2020年12月30日后不再显示,谢谢。

A:=(3*C+L+O+H)/6;
B:(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;

D:MA(B,M);

我的要求:DKX指标加入一个时间显示限制,2020年12月30日后不再显示,谢谢。

A:=(3*C+L+O+H)/6;
B:(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;

D:MA(B,M);

付费偷看设置
发送
1条回答
文华解答
1楼 · 01-23 10:45.采纳回答
参考:

T:=DATE<201230;
A:=(3*C+L+O+H)/6;
B:IF(T,(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210,NULL);

D:IF(T,MA(B,M),NULL);