指标中有未来函数吗

01-19 18:04发布

DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:2*(DIFF-DEA),COLORSTICK;
JC:=CROSS(DIFF,DEA);
SC:=CROSSDOWN(DIFF,DEA);
N1:=BARSLAST(JC)+1;
N2:=BARSLAST(SC)+1;

HH:=MACD=REFX(HHV(MACD,8),4) && MACD>0;
DRAWICON(HH,MACD,1),VALIGN2;

CON1:=HH && MACDREF(H,SUMBARS(HH,2)-1) && REF(H,SUMBARS(HH,2)-1)>REF(H,SUMBARS(HH,3)-1);
VERTLINE1(CON1);

DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:2*(DIFF-DEA),COLORSTICK;
JC:=CROSS(DIFF,DEA);
SC:=CROSSDOWN(DIFF,DEA);
N1:=BARSLAST(JC)+1;
N2:=BARSLAST(SC)+1;

HH:=MACD=REFX(HHV(MACD,8),4) && MACD>0;
DRAWICON(HH,MACD,1),VALIGN2;

CON1:=HH && MACDREF(H,SUMBARS(HH,2)-1) && REF(H,SUMBARS(HH,2)-1)>REF(H,SUMBARS(HH,3)-1);
VERTLINE1(CON1);

付费偷看设置
发送
9条回答
文华解答
2楼-- · 01-19 18:59
1楼编写有未来函数REFX
您可以在编写界面 插入函数 》未来函数 里了解下相关未来函数
文华问答
3楼-- · 01-19 19:20
这个主要是顶背离吧
文华问答
4楼-- · 01-19 19:40
可以按这个思路写一个底背离吗
文华问答
5楼-- · 01-19 20:00
写一个底背离,然后二个合一个
文华解答
6楼-- · 01-19 20:20
参考:

DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:2*(DIFF-DEA),COLORSTICK;
JC:=CROSS(DIFF,DEA);
SC:=CROSSDOWN(DIFF,DEA);
N1:=BARSLAST(JC)+1;
N2:=BARSLAST(SC)+1;
HH:=MACD=REFX(HHV(MACD,8),4) && MACD>0;
DRAWICON(HH,MACD,1),VALIGN2;
CON1:=HH && MACDREF(H,SUMBARS(HH,2)-1) && REF(H,SUMBARS(HH,2)-1)>REF(H,SUMBARS(HH,3)-1);
VERTLINE1(CON1);


LL:=MACD=REFX(LLV(MACD,8),4) && MACD<0;
DRAWICON(LL,MACD,2),VALIGN0;
CON2:=LL && MACD>REF(MACD,SUMBARS(LL,2)-1) && REF(MACD,SUMBARS(LL,2)-1)>REF(MACD,SUMBARS(LL,3)-1) && L
VERTLINE1(CON2),COLORYELLOW;

文华问答
7楼-- · 01-19 20:39
帮忙把其他的全部去掉,只保留竖线,数线用颜色区别一下