老师,帮忙修改高低价指标

01-11 21:31发布

VV:"DAY$1$VOL",NODRAW;



N:=BARSLAST(VV<>REF(VV,1))+1;
OO:REF(VALUEWHEN(N=1,O),N),NODRAW;
HH:REF(HHV(H,N),N),NODRAW;
LL:REF(LLV(L,N),N),NODRAW;
CC:REF(C,N),NODRAW;
DRAWSL1(REFX(N=1,1)||ISLASTBAR,OO,0,N,1),COLORYELLOW;
DRAWSL1(REFX(N=1,1)||ISLASTBAR,HH,0,N,1),COLORYELLOW;
DRAWSL1(REFX(N=1,1)||ISLASTBAR,LL,0,N,1),COLORYELLOW;
DRAWSL1(REFX(N=1,1)||ISLASTBAR,CC,0,N,1),COLORYELLOW;
DRAWICON(CROSS(C,OO)||CROSSDOWN(C,OO),H+20,1);
CROSS(C,OO)||CROSSDOWN(C,OO),SOUND('V');
DRAWICON(CROSS(C,HH)||CROSSDOWN(C,HH),H+20,1);
CROSS(C,HH)||CROSSDOWN(C,HH),SOUND('V');
DRAWICON(CROSS(C,LL)||CROSSDOWN(C,LL),H+20,1);
CROSS(C,LL)||CROSSDOWN(C,LL),SOUND('V');
DRAWICON(CROSS(C,CC)||CROSSDOWN(C,CC),H+20,1);
CROSS(C,CC)||CROSSDOWN(C,CC),SOUND('V');

把笑脸去掉,横线后面写上:开盘价收盘价最高价最低价,横线后面标注数值,声音:价格触碰横线预警

VV:"DAY$1$VOL",NODRAW;


N:=BARSLAST(VV<>REF(VV,1))+1;
OO:REF(VALUEWHEN(N=1,O),N),NODRAW;
HH:REF(HHV(H,N),N),NODRAW;
LL:REF(LLV(L,N),N),NODRAW;
CC:REF(C,N),NODRAW;
DRAWSL1(REFX(N=1,1)||ISLASTBAR,OO,0,N,1),COLORYELLOW;
DRAWSL1(REFX(N=1,1)||ISLASTBAR,HH,0,N,1),COLORYELLOW;
DRAWSL1(REFX(N=1,1)||ISLASTBAR,LL,0,N,1),COLORYELLOW;
DRAWSL1(REFX(N=1,1)||ISLASTBAR,CC,0,N,1),COLORYELLOW;
DRAWICON(CROSS(C,OO)||CROSSDOWN(C,OO),H+20,1);
CROSS(C,OO)||CROSSDOWN(C,OO),SOUND('V');
DRAWICON(CROSS(C,HH)||CROSSDOWN(C,HH),H+20,1);
CROSS(C,HH)||CROSSDOWN(C,HH),SOUND('V');
DRAWICON(CROSS(C,LL)||CROSSDOWN(C,LL),H+20,1);
CROSS(C,LL)||CROSSDOWN(C,LL),SOUND('V');
DRAWICON(CROSS(C,CC)||CROSSDOWN(C,CC),H+20,1);
CROSS(C,CC)||CROSSDOWN(C,CC),SOUND('V');

把笑脸去掉,横线后面写上:开盘价收盘价最高价最低价,横线后面标注数值,声音:价格触碰横线预警

付费偷看设置
发送
9条回答
文华解答
2楼-- · 01-11 22:45
参考:

VV:"DAY$1$VOL",NODRAW;

N:=BARSLAST(VV<>REF(VV,1))+1;
OO:REF(VALUEWHEN(N=1,O),N),NODRAW;
HH:REF(HHV(H,N),N),NODRAW;
LL:REF(LLV(L,N),N),NODRAW;
CC:REF(C,N),NODRAW;
DRAWSL1(REFX(N=1,1)||ISLASTBAR,OO,0,N,1),COLORYELLOW;
DRAWSL1(REFX(N=1,1)||ISLASTBAR,HH,0,N,1),COLORYELLOW;
DRAWSL1(REFX(N=1,1)||ISLASTBAR,LL,0,N,1),COLORYELLOW;
DRAWSL1(REFX(N=1,1)||ISLASTBAR,CC,0,N,1),COLORYELLOW;

DRAWTEXT(REFX(N=1,1)||ISLASTBAR,OO,'开盘价'),ALIGN2;
DRAWTEXT(REFX(N=1,1)||ISLASTBAR,HH,'最高价'),ALIGN2;
DRAWTEXT(REFX(N=1,1)||ISLASTBAR,LL,'最低价'),ALIGN2;
DRAWTEXT(REFX(N=1,1)||ISLASTBAR,CC,'收盘价'),ALIGN2;

DRAWNUMBER1(REFX(N=1,1)||ISLASTBAR,OO,OO,0),ALIGN0;
DRAWNUMBER1(REFX(N=1,1)||ISLASTBAR,HH,HH,0),ALIGN0;
DRAWNUMBER1(REFX(N=1,1)||ISLASTBAR,LL,LL,0),ALIGN0;
DRAWNUMBER1(REFX(N=1,1)||ISLASTBAR,CC,CC,0),ALIGN0;

CROSS(C,OO)||CROSSDOWN(C,OO),SOUND('V');
CROSS(C,HH)||CROSSDOWN(C,HH),SOUND('V');
CROSS(C,LL)||CROSSDOWN(C,LL),SOUND('V');
CROSS(C,CC)||CROSSDOWN(C,CC),SOUND('V');
不悔用文华
3楼-- · 01-11 23:05
保留N1天划线,请老师把它设计用N1控制,N1自定义
文华解答
4楼-- · 01-11 23:26
参考:

N1:=5;
VV:"DAY$1$VOL",NODRAW;
T:=BACKSET(ISLASTBAR,SUMBARS(DAYBARPOS=1,N1));
N:=BARSLAST(VV<>REF(VV,1))+1;
OO:REF(VALUEWHEN(N=1,O),N),NODRAW;
HH:REF(HHV(H,N),N),NODRAW;
LL:REF(LLV(L,N),N),NODRAW;
CC:REF(C,N),NODRAW;
DRAWSL1(T&&(REFX(N=1,1)||ISLASTBAR),OO,0,N,1),COLORYELLOW;
DRAWSL1(T&&(REFX(N=1,1)||ISLASTBAR),HH,0,N,1),COLORYELLOW;
DRAWSL1(T&&(REFX(N=1,1)||ISLASTBAR),LL,0,N,1),COLORYELLOW;
DRAWSL1(T&&(REFX(N=1,1)||ISLASTBAR),CC,0,N,1),COLORYELLOW;

DRAWTEXT(T&&(REFX(N=1,1)||ISLASTBAR),OO,'开盘价'),ALIGN2;
DRAWTEXT(T&&(REFX(N=1,1)||ISLASTBAR),HH,'最高价'),ALIGN2;
DRAWTEXT(T&&(REFX(N=1,1)||ISLASTBAR),LL,'最低价'),ALIGN2;
DRAWTEXT(T&&(REFX(N=1,1)||ISLASTBAR),CC,'收盘价'),ALIGN2;

DRAWNUMBER1(T&&(REFX(N=1,1)||ISLASTBAR),OO,OO,0),ALIGN0;
DRAWNUMBER1(T&&(REFX(N=1,1)||ISLASTBAR),HH,HH,0),ALIGN0;
DRAWNUMBER1(T&&(REFX(N=1,1)||ISLASTBAR),LL,LL,0),ALIGN0;
DRAWNUMBER1(T&&(REFX(N=1,1)||ISLASTBAR),CC,CC,0),ALIGN0;

CROSS(C,OO)||CROSSDOWN(C,OO),SOUND('V');
CROSS(C,HH)||CROSSDOWN(C,HH),SOUND('V');
CROSS(C,LL)||CROSSDOWN(C,LL),SOUND('V');
CROSS(C,CC)||CROSSDOWN(C,CC),SOUND('V');
不悔用文华
5楼-- · 01-11 23:45
老师,帮忙加载一个条件:今天的开盘价,今开价,谢谢
不悔用文华
6楼-- · 01-12 00:05
老师,帮忙加载一个条件:今天的开盘价,今开价,谢谢,声音预警也是一样的

文华解答
7楼-- · 01-12 00:25
参考:

N1:=5;
VV:"DAY$1$VOL",NODRAW;
T:=BACKSET(ISLASTBAR,SUMBARS(DAYBARPOS=1,N1));
N:=BARSLAST(VV<>REF(VV,1))+1;
OO:REF(VALUEWHEN(N=1,O),N),NODRAW;
HH:REF(HHV(H,N),N),NODRAW;
LL:REF(LLV(L,N),N),NODRAW;
CC:REF(C,N),NODRAW;
JO:VALUEWHEN(DAYBARPOS=1,O),NODRAW;
DRAWSL1(T&&(REFX(N=1,1)||ISLASTBAR),OO,0,N,1),COLORYELLOW;
DRAWSL1(T&&(REFX(N=1,1)||ISLASTBAR),HH,0,N,1),COLORYELLOW;
DRAWSL1(T&&(REFX(N=1,1)||ISLASTBAR),LL,0,N,1),COLORYELLOW;
DRAWSL1(T&&(REFX(N=1,1)||ISLASTBAR),CC,0,N,1),COLORYELLOW;
DRAWSL1(T&&(REFX(N=1,1)||ISLASTBAR),JO,0,N,1),COLORYELLOW;

DRAWTEXT(T&&(REFX(N=1,1)||ISLASTBAR),OO,'开盘价'),ALIGN2;
DRAWTEXT(T&&(REFX(N=1,1)||ISLASTBAR),HH,'最高价'),ALIGN2;
DRAWTEXT(T&&(REFX(N=1,1)||ISLASTBAR),LL,'最低价'),ALIGN2;
DRAWTEXT(T&&(REFX(N=1,1)||ISLASTBAR),CC,'收盘价'),ALIGN2;
DRAWTEXT(T&&(REFX(N=1,1)||ISLASTBAR),JO,'今开价'),ALIGN2;

DRAWNUMBER1(T&&(REFX(N=1,1)||ISLASTBAR),OO,OO,0),ALIGN0;
DRAWNUMBER1(T&&(REFX(N=1,1)||ISLASTBAR),HH,HH,0),ALIGN0;
DRAWNUMBER1(T&&(REFX(N=1,1)||ISLASTBAR),LL,LL,0),ALIGN0;
DRAWNUMBER1(T&&(REFX(N=1,1)||ISLASTBAR),CC,CC,0),ALIGN0;
DRAWNUMBER1(T&&(REFX(N=1,1)||ISLASTBAR),JO,JO,0),ALIGN0;

CROSS(C,OO)||CROSSDOWN(C,OO),SOUND('V');
CROSS(C,HH)||CROSSDOWN(C,HH),SOUND('V');
CROSS(C,LL)||CROSSDOWN(C,LL),SOUND('V');
CROSS(C,CC)||CROSSDOWN(C,CC),SOUND('V');
CROSS(C,JO)||CROSSDOWN(C,JO),SOUND('V');