请老师写个均线指标

01-11 21:46发布

两条均线,EMA21和EMA60,均线不在主图显示出来。 当21和60多排时,SLOWKD在60以下金叉,K线用一个向上的箭头表示和声音提醒; 当21和60空排时,SLOWKD在60以上死叉...

两条均线,EMA21和EMA60,均线不在主图显示出来。

当21和60多排时,SLOWKD在60以下金叉,K线用一个向上的箭头表示和声音提醒;
当21和60空排时,SLOWKD在60以上死叉,K线用一个向下的箭头表示和声音提醒


谢谢老师!
付费偷看设置
发送
3条回答
文华解答
2楼-- · 01-11 22:41
参考:



EMA21:=EMA(C,21);
EMA60:=EMA(C,60);

N:=9;
M1:=3;
M2:=3;
M3:=3;
RSV:= (CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;//
FASTK:=SMA(RSV,M1,1);//RSV的移动平均值
K:=SMA(FASTK,M2,1);//FASTK的移动平均值
D:=SMA(K,M3,1);//K的移动平均值

DRAWICON(EMA21>EMA60 && K<60 && CROSS(K,D),H,'ICO4');
DRAWICON(EMA2160 && CROSSDOWN(K,D),H,'ICO5');

EMA21>EMA60 && K<60 && CROSS(K,D),SOUND('A');
EMA2160 && CROSSDOWN(K,D),SOUND('B');
不悔用文华
3楼-- · 01-11 23:00
老师,红色箭头可以写在K线下面吗?
文华解答
4楼-- · 01-11 23:20
参考:



EMA21:=EMA(C,21);
EMA60:=EMA(C,60);

N:=9;
M1:=3;
M2:=3;
M3:=3;
RSV:= (CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;//
FASTK:=SMA(RSV,M1,1);//RSV的移动平均值
K:=SMA(FASTK,M2,1);//FASTK的移动平均值
D:=SMA(K,M3,1);//K的移动平均值

DRAWICON(EMA21>EMA60 && K<60 && CROSS(K,D),H,'ICO4');
DRAWICON(EMA2160 && CROSSDOWN(K,D),L,'ICO5'),VALIGN0;

EMA21>EMA60 && K<60 && CROSS(K,D),SOUND('A');
EMA2160 && CROSSDOWN(K,D),SOUND('B');