修改指标线颜色

12-01 21:12发布

老师好!帮忙改一下信号竖线的颜色,卖出变成墨绿,卖入竖线信号的颜色为紫红色,多谢!
MA1:=MA(C,N1);
MA2:=MA(C,N2);
AA:=CROSS(MA1>REF(MA1,1)&&C>MA1&&C>MA2&&MA1-MA2<=6&&C-MA2<=10,0.5);
BB:=CROSS(MA1 VERTLINE(CROSS(BARSLAST(CROSSDOWN(C,MA2)),BARSLAST(AA)),COLORRED);
VERTLINE(CROSS(BARSLAST(CROSS(C,MA2)),BARSLAST(BB)),COLORGREEN);
CROSS(BARSLAST(CROSSDOWN(C,MA2)),BARSLAST(AA)),SOUND('A');
CROSS(BARSLAST(CROSS(C,MA2)),BARSLAST(BB)),SOUND('B');
DRAWTEXT(CROSS(BARSLAST(CROSSDOWN(C,MA2)),BARSLAST(AA)),L,'3FZ C'),ALIGN0,COLORYELLOW,VALIGN0;
DRAWTEXT(CROSS(BARSLAST(CROSS(C,MA2)),BARSLAST(BB)),L,'3FZ C'),ALIGN0,COLORYELLOW,VALIGN0;

老师好!帮忙改一下信号竖线的颜色,卖出变成墨绿,卖入竖线信号的颜色为紫红色,多谢!
MA1:=MA(C,N1);
MA2:=MA(C,N2);
AA:=CROSS(MA1>REF(MA1,1)&&C>MA1&&C>MA2&&MA1-MA2<=6&&C-MA2<=10,0.5);
BB:=CROSS(MA1 VERTLINE(CROSS(BARSLAST(CROSSDOWN(C,MA2)),BARSLAST(AA)),COLORRED);
VERTLINE(CROSS(BARSLAST(CROSS(C,MA2)),BARSLAST(BB)),COLORGREEN);
CROSS(BARSLAST(CROSSDOWN(C,MA2)),BARSLAST(AA)),SOUND('A');
CROSS(BARSLAST(CROSS(C,MA2)),BARSLAST(BB)),SOUND('B');
DRAWTEXT(CROSS(BARSLAST(CROSSDOWN(C,MA2)),BARSLAST(AA)),L,'3FZ C'),ALIGN0,COLORYELLOW,VALIGN0;
DRAWTEXT(CROSS(BARSLAST(CROSS(C,MA2)),BARSLAST(BB)),L,'3FZ C'),ALIGN0,COLORYELLOW,VALIGN0;

付费偷看设置
发送
1条回答
文华解答
1楼 · 12-01 21:54.采纳回答

参考


MA1:=MA(C,N1);

MA2:=MA(C,N2);

AA:=CROSS(MA1>REF(MA1,1)&&C>MA1&&C>MA2&&MA1-MA2<=6&&C-MA2<=10,0.5);

BB:=CROSS(MA1

VERTLINE(CROSS(BARSLAST(CROSSDOWN(C,MA2)),BARSLAST(AA)),COLORMAGENTA);

VERTLINE(CROSS(BARSLAST(CROSS(C,MA2)),BARSLAST(BB)),COLORLIGHTGREEN);

CROSS(BARSLAST(CROSSDOWN(C,MA2)),BARSLAST(AA)),SOUND('A');

CROSS(BARSLAST(CROSS(C,MA2)),BARSLAST(BB)),SOUND('B');

DRAWTEXT(CROSS(BARSLAST(CROSSDOWN(C,MA2)),BARSLAST(AA)),L,'3FZ C'),ALIGN0,COLORYELLOW,VALIGN0;

DRAWTEXT(CROSS(BARSLAST(CROSS(C,MA2)),BARSLAST(BB)),L,'3FZ C'),ALIGN0,COLORYELLOW,VALIGN0;