[求助]麻烦老师改下公式

10-24 09:58发布

T1R:=XMA(XMA(XMA(EMA(CLOSE,1),2),2),2);

TR1:=EMA((T1R-REF(T1R,1))/REF(T1R,1),1)*1000,COLORFF00FF,NODRAW;

净:=XMA(TR1,11);

流:=EMA(净,11);

主力动向:=EMA(净+流,1)-XMA(净-流,2),COLORFF00FF,NODRAW;

MA1:XMA(主力动向,11),COLORFF00FF,NODRAW;

MA3:EMA(MA1,2);

DRAWTEXT(CROSS(MA3,MA1),(MA3 *1.12),'抛'),COLORYELLOW;

DRAWTEXT(CROSS(0,MA1),2,'空'),COLOR00FFFF;

DRAWTEXT(CROSS(MA1,0),-4,'买'),COLORFF00FF;

DRAWTEXT(CROSS(MA1,MA3),(MA3 *1.2),'低吸'),COLORYELLOW;

STICKLINE(MA1>=0 AND MA1>=REF(MA1,1),0,MA1,1.2,1),COLORRED;

STICKLINE(MA1>=0 AND MA1

STICKLINE(MA1<0 AND MA1>=REF(MA1,1),0,MA1,1.5,0),COLORFF00FF;

STICKLINE(MA1<0 AND MA1

STICKLINE(MA1<=0 AND MA1>=REF(MA1,1),0 ,MA1,3,0),COLORFF6600;

STICKLINE(MA1<=0 AND MA1>=REF(MA1,1),0,MA1,2,0),COLORFF9900;

STICKLINE(MA1<=0 AND MA1>=REF(MA1,1),0,MA1,1.5,0),COLORFFCC00;

STICKLINE(MA1<=0 AND MA1>=REF(MA1,1),0,MA1,0.5,0),COLORCYAN;

STICKLINE(MA1>=0 AND MA1>=REF(MA1,1),0,MA1,3,0),COLOR000099;

STICKLINE(MA1>=0 AND MA1>=REF(MA1,1),0,MA1,2,0),COLOR0000CC;

STICKLINE(MA1>=0 AND MA1>=REF(MA1,1),0,MA1,1.5,0),COLOR0000FF;

STICKLINE(MA1>=0 AND MA1>=REF(MA1,1),0,MA1,0.5,0),COLORCC66FF;

T1R:=XMA(XMA(XMA(EMA(CLOSE,1),2),2),2);

TR1:=EMA((T1R-REF(T1R,1))/REF(T1R,1),1)*1000,COLORFF00FF,NODRAW;

净:=XMA(TR1,11);

流:=EMA(净,11);

主力动向:=EMA(净+流,1)-XMA(净-流,2),COLORFF00FF,NODRAW;

MA1:XMA(主力动向,11),COLORFF00FF,NODRAW;

MA3:EMA(MA1,2);

DRAWTEXT(CROSS(MA3,MA1),(MA3 *1.12),'抛'),COLORYELLOW;

DRAWTEXT(CROSS(0,MA1),2,'空'),COLOR00FFFF;

DRAWTEXT(CROSS(MA1,0),-4,'买'),COLORFF00FF;

DRAWTEXT(CROSS(MA1,MA3),(MA3 *1.2),'低吸'),COLORYELLOW;

STICKLINE(MA1>=0 AND MA1>=REF(MA1,1),0,MA1,1.2,1),COLORRED;

STICKLINE(MA1>=0 AND MA1

STICKLINE(MA1<0 AND MA1>=REF(MA1,1),0,MA1,1.5,0),COLORFF00FF;

STICKLINE(MA1<0 AND MA1

STICKLINE(MA1<=0 AND MA1>=REF(MA1,1),0 ,MA1,3,0),COLORFF6600;

STICKLINE(MA1<=0 AND MA1>=REF(MA1,1),0,MA1,2,0),COLORFF9900;

STICKLINE(MA1<=0 AND MA1>=REF(MA1,1),0,MA1,1.5,0),COLORFFCC00;

STICKLINE(MA1<=0 AND MA1>=REF(MA1,1),0,MA1,0.5,0),COLORCYAN;

STICKLINE(MA1>=0 AND MA1>=REF(MA1,1),0,MA1,3,0),COLOR000099;

STICKLINE(MA1>=0 AND MA1>=REF(MA1,1),0,MA1,2,0),COLOR0000CC;

STICKLINE(MA1>=0 AND MA1>=REF(MA1,1),0,MA1,1.5,0),COLOR0000FF;

STICKLINE(MA1>=0 AND MA1>=REF(MA1,1),0,MA1,0.5,0),COLORCC66FF;

付费偷看设置
发送
3条回答
文华解答
2楼-- · 10-24 11:00
参考:

T1R:=REFX1(REFX(REFX1(EMA(CLOSE,1),10000),10000),10000);

TR1:=EMA((T1R-REF(T1R,1))/REF(T1R,1),1)*1000,COLORFF00FF,NODRAW;

净:=REFX1(TR1,10000);

流:=EMA(净,11);

主力动向:=EMA(净+流,1)-REFX1(净-流,10000),COLORFF00FF,NODRAW;

MA1:REFX1(主力动向,10000),COLORFF00FF,NODRAW;

MA3:EMA(MA1,2);

DRAWTEXT(CROSS(MA3,MA1),(MA3 *1.12),'抛'),COLORYELLOW;

DRAWTEXT(CROSS(0,MA1),2,'空'),COLOR00FFFF;

DRAWTEXT(CROSS(MA1,0),-4,'买'),COLORFF00FF;

DRAWTEXT(CROSS(MA1,MA3),(MA3 *1.2),'低吸'),COLORYELLOW;

STICKLINE(MA1>=0 AND MA1>=REF(MA1,1),0,MA1,1.2,1),COLORRED;

STICKLINE(MA1>=0 AND MA1

STICKLINE(MA1<0 AND MA1>=REF(MA1,1),0,MA1,1.5,0),COLORFF00FF;

STICKLINE(MA1<0 AND MA1

STICKLINE(MA1<=0 AND MA1>=REF(MA1,1),0 ,MA1,3,0),COLORFF6600;

STICKLINE(MA1<=0 AND MA1>=REF(MA1,1),0,MA1,2,0),COLORFF9900;

STICKLINE(MA1<=0 AND MA1>=REF(MA1,1),0,MA1,1.5,0),COLORFFCC00;

STICKLINE(MA1<=0 AND MA1>=REF(MA1,1),0,MA1,0.5,0),COLORCYAN;

STICKLINE(MA1>=0 AND MA1>=REF(MA1,1),0,MA1,3,0),COLOR000099;

STICKLINE(MA1>=0 AND MA1>=REF(MA1,1),0,MA1,2,0),COLOR0000CC;

STICKLINE(MA1>=0 AND MA1>=REF(MA1,1),0,MA1,1.5,0),COLOR0000FF;

STICKLINE(MA1>=0 AND MA1>=REF(MA1,1),0,MA1,0.5,0),COLORCC66FF;
文华菜鸟
3楼-- · 10-24 11:21
以下是引用雨露在2020/8/3 20:30:00的发言:
参考:

T1R:=REFX1(REFX(REFX1(EMA(CLOSE,1),10000),10000),10000);

TR1:=EMA((T1R-REF(T1R,1))/REF(T1R,1),1)*1000,COLORFF00FF,NODRAW;

净:=REFX1(TR1,10000);

流:=EMA(净,11);

主力动向:=EMA(净+流,1)-REFX1(净-流,10000),COLORFF00FF,NODRAW;

MA1:REFX1(主力动向,10000),COLORFF00FF,NODRAW;

MA3:EMA(MA1,2);

DRAWTEXT(CROSS(MA3,MA1),(MA3 *1.12),'抛'),COLORYELLOW;

DRAWTEXT(CROSS(0,MA1),2,'空'),COLOR00FFFF;

DRAWTEXT(CROSS(MA1,0),-4,'买'),COLORFF00FF;

DRAWTEXT(CROSS(MA1,MA3),(MA3 *1.2),'低吸'),COLORYELLOW;

STICKLINE(MA1>=0 AND MA1>=REF(MA1,1),0,MA1,1.2,1),COLORRED;

STICKLINE(MA1>=0 AND MA1

STICKLINE(MA1<0 AND MA1>=REF(MA1,1),0,MA1,1.5,0),COLORFF00FF;

STICKLINE(MA1<0 AND MA1

STICKLINE(MA1<=0 AND MA1>=REF(MA1,1),0 ,MA1,3,0),COLORFF6600;

STICKLINE(MA1<=0 AND MA1>=REF(MA1,1),0,MA1,2,0),COLORFF9900;

STICKLINE(MA1<=0 AND MA1>=REF(MA1,1),0,MA1,1.5,0),COLORFFCC00;

STICKLINE(MA1<=0 AND MA1>=REF(MA1,1),0,MA1,0.5,0),COLORCYAN;

STICKLINE(MA1>=0 AND MA1>=REF(MA1,1),0,MA1,3,0),COLOR000099;

STICKLINE(MA1>=0 AND MA1>=REF(MA1,1),0,MA1,2,0),COLOR0000CC;

STICKLINE(MA1>=0 AND MA1>=REF(MA1,1),0,MA1,1.5,0),COLOR0000FF;

STICKLINE(MA1>=0 AND MA1>=REF(MA1,1),0,MA1,0.5,0),COLORCC66FF;

老师,指标怎么什么内容都没有,空白的
文华解答
4楼-- · 10-24 11:41
您的这个指标主体用到了XMA函数

XMA是其他软件特有函数,只能近似改写实现

不同软件对函数的处理略有不同,加载效果略有差异是正常的,请您理解
Copyright © 2020 自动化交易