老师修改公式

10-16 21:05发布

以收盘价算

当kd在打大于50上方死叉,并且macd的diff大于dea时标记并报警

当kd在打小于50下方死叉,并且macd的diff小于dea时标记并报警


以收盘价算
当kd在打大于50上方死叉,并且macd的diff大于dea时标记并报警

当kd在打小于50下方死叉,并且macd的diff小于dea时标记并报警


付费偷看设置
发送
9条回答
文华解答
2楼-- · 10-16 22:31
红绿点,声音提醒,参考:

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
DIFF :=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA :=EMA(DIFF,9);
MACD:=2*(DIFF-DEA),COLORSTICK;
CON1:=MIN(K,D)>50 && CROSSDOWN(K,D) && MACD>0;
CON2:=MAX(K,D)<50 && CROSSDOWN(K,D) && MACD<0;
DRAWICON(CON1,H,'ICO10');
DRAWICON(CON2,H,'ICO11');
CON1||CON2,SOUND('A');
文华菜鸟
3楼-- · 10-16 22:50
以收盘价算
当kd在打大于50上方死叉,并且macd(前两根k线)的diff大于dea时标记并报警()内为修改;

当kd在打小于50下方死叉,并且macd(前两根k线)的diff小于dea时标记并报警()内为修改;

预警点不变
文华解答
4楼-- · 10-16 23:11
参考:

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
DIFF :=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA),COLORSTICK;
CON1:=MIN(K,D)>50 && CROSSDOWN(K,D) && REF(COUNT(MACD>0,2)=2,1);
CON2:=MAX(K,D)<50 && CROSSDOWN(K,D) && REF(COUNT(MACD<0,2)=2,1);
DRAWICON(CON1,H,'ICO10');
DRAWICON(CON2,H,'ICO11');
CON1||CON2,SOUND('A');
文华菜鸟
5楼-- · 10-16 23:31
老师请把4楼公式改成附图kd指标看一下
文华解答
6楼-- · 10-16 23:51
参考:

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1);
D:SMA(K,3,1);
DIFF :=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA),COLORSTICK;
CON1:=MIN(K,D)>50 && CROSSDOWN(K,D) && REF(COUNT(MACD>0,2)=2,1);
CON2:=MAX(K,D)<50 && CROSSDOWN(K,D) && REF(COUNT(MACD<0,2)=2,1);
DRAWICON(CON1,K,'ICO10');
DRAWICON(CON2,K,'ICO11');
CON1||CON2,SOUND('A');

文华菜鸟
7楼-- · 10-17 00:11
文化7用

K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
DIFF :=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA),COLORSTICK;
CON1:=MIN(K,D)>50 && CROSSDOWN(K,D) && REF(COUNT(MACD>0,2)=2,1);
CON2:=MAX(K,D)<50 && CROSSDOWN(K,D) && REF(COUNT(MACD<0,2)=2,1);
DRAWICON(CON1,H,'ICO10');
DRAWICON(CON2,H,'ICO11');
CON1||CON2,SOUND('A');

预警列表并没有显示?仅有声音提示