K线价格上穿5 10 20 均线

10-16 21:34发布

老师帮写个指标K线价格上穿和下破5 10 20。并标示买和卖

老师帮写个指标K线价格上穿和下破5 10 20。并标示买和卖
付费偷看设置
发送
3条回答
文华解答
2楼-- · 10-16 22:30
确认下,您的上穿和下破。

如上穿,是首次收盘价全部大于5、10、20?
还是K线最低价低于3个均线的最低同时最高价高于3个均线最低?
无知无畏
3楼-- · 10-16 22:50
收盘价格 老师
文华解答
4楼-- · 10-16 23:09
参考:

MA5:MA(C,5);
MA10:MA(C,10);
MA20:MA(C,20);

A:=CROSS(C>MA5&&C>MA10&&C>MA20,0.5);
B:=CROSS(C
DRAWTEXT(A&&COUNT(A,BARSLAST(B))=1,L,'买'),VALIGN0;
DRAWTEXT(B&&COUNT(B,BARSLAST(A))=1,H,'卖');