指标公式编写

10-16 21:27发布

老师 请帮写一个 当某根阳K线收盘价收在连续前两根K线的最高价之上 在此K线下方标准红色箭头
当某根阴K线收盘价收在连续前两根K线的最低价之下 在此K线上方标准绿色箭头

老师 请帮写一个 当某根阳K线收盘价收在连续前两根K线的最高价之上 在此K线下方标准红色箭头
当某根阴K线收盘价收在连续前两根K线的最低价之下 在此K线上方标准绿色箭头
付费偷看设置
发送
9条回答
文华解答
2楼-- · 10-16 22:26

参考:

AA:=ISUP&&CROSS(CLOSE,HV(H,2));
BB:=ISDOWN&&CROSSDOWN(CLOSE,LV(L,2));
DRAWICON(AA,L,4),VALIGN0;
DRAWICON(BB,H,5),VALIGN2;

不悔用文华
3楼-- · 10-16 22:46
老师能否修改 连续两个及以上的多空信号 只显示第一个
文华解答
4楼-- · 10-16 23:06

参考:

AA:=ISUP&&CROSS(CLOSE,HV(H,2))&&SUM(CROSS(C,HV(H,2)),DAYBARPOS);
BB:=ISDOWN&&CROSSDOWN(CLOSE,LV(L,2))&&SUM(CROSSDOWN(C,LV(L,2)),DAYBARPOS);
DRAWICON(AA,L,4),VALIGN0;
DRAWICON(BB,H,5),VALIGN2;

不悔用文华
5楼-- · 10-16 23:25
老师不对 我是说连续两个及以上的 多或空 信号 只显示第一个 也就是只有空到多 多到空 信号 ,图表上显示就是两个多中间一个空 两个空中间一个多
文华解答
6楼-- · 10-16 23:46

参考:

AA:=ISUP&&CROSS(CLOSE,HV(H,2))&&SUM(CROSS(C,HV(H,2)),DAYBARPOS);
BB:=ISDOWN&&CROSSDOWN(CLOSE,LV(L,2))&&SUM(CROSSDOWN(C,LV(L,2)),DAYBARPOS);
DRAWICON(AA&&COUNT(AA,BARSLAST(BB)+1)=1,L,4),VALIGN0;
DRAWICON(BB&&COUNT(BB,BARSLAST(AA)+1)=1,H,5),VALIGN2;

不悔用文华
7楼-- · 10-17 00:05
老师 能否再看看 修改 谢谢