[求助]请教老师

10-16 21:13发布

boll参数12

MA90
MA20
MA30
MA50
MA20MA90小于boll下轨,MA90小于MA20,MA30MA50在boll内部时声音表情提示一次,直到MA20交叉下轨之前就声音表情就提示一次。公式怎么编写

boll参数12
MA90
MA20
MA30
MA50
MA20MA90小于boll下轨,MA90小于MA20,MA30MA50在boll内部时声音表情提示一次,直到MA20交叉下轨之前就声音表情就提示一次。公式怎么编写
付费偷看设置
发送
9条回答
文华解答
2楼-- · 10-16 22:25
参考:


MID:MA(CLOSE,26);
TMP2:=STD(CLOSE,26);
TOP:MID+2*TMP2;
BOTTOM:MID-2*TMP2;

MA90:MA(C,90);
MA20:MA(C,20);
MA30:MA(C,30);
MA50:MA(C,50);


A:=MA90MA90&&MA30>BOTTOM&&MA30BOTTOM&&MA50
DRAWICON(CROSS(A,0.5),H,1);
B:=CROSSDOWN(MA20,BOTTOM);
DRAWICON(CROSS(B,0.5),H,2);

CROSS(A,0.5)||CROSS(B,0.5),SOUND('A');

不悔用文华
3楼-- · 10-16 22:45
老师这个改一下:MA20MA90小于boll下轨,MA90小于MA20,MA30MA50在boll内部时声音表情提示一次
改成:
MA90是从boll内部交叉boll下轨后来到boll外部,之后MA20MA90小于boll下轨,MA90小于MA20,MA30MA50在boll内部时声音表情提示一次
文华解答
4楼-- · 10-16 23:05
MA90是从boll内部交叉boll下轨后来到boll外部,就是指MA90死叉下轨?

在死叉的时候满足后面的条件进行提示?

不悔用文华
5楼-- · 10-16 23:24
是的
文华解答
6楼-- · 10-16 23:45
参考:

MID:MA(CLOSE,26);
TMP2:=STD(CLOSE,26);
TOP:MID+2*TMP2;
BOTTOM:MID-2*TMP2;

MA90:MA(C,90);
MA20:MA(C,20);
MA30:MA(C,30);
MA50:MA(C,50);


A:=CROSSDOWN(MA90,BOTTOM)&&MA20MA90&&MA30>BOTTOM&&MA30BOTTOM&&MA50
DRAWICON(CROSS(A,0.5),H,1);
B:=CROSSDOWN(MA20,BOTTOM);
DRAWICON(CROSS(B,0.5),H,2);
不悔用文华
7楼-- · 10-17 00:05
CROSSDOWN(MA90,BOTTOM)能不能把MA90交叉下轨作为前置条件,而不是在这个条件满足的时候去做最终的判断