[求助]指标改写模型

09-15 21:21发布

麻烦老师吧下面两个指标改写模型WH7信号提示用,收盘价突破提示信号并闪屏或提示音;谢谢 一: HH:=HHV(HIGH,10);LL:=LLV(LOW,10);HH1:=BARSLAST((HH ...

麻烦老师吧下面两个指标改写模型WH7信号提示用,收盘价突破提示信号并闪屏或提示音;谢谢
一:
HH:=HHV(HIGH,10);
LL:=LLV(LOW,10);
HH1:=BARSLAST((HH > REF(HH,1)));
LL1:=BARSLAST((LL < REF(LL,1)));
PARTLINE((HH1 < LL1),LL,COLORRED);
PARTLINE((HH1 > LL1),HH,COLORCYAN);
STICKLINE((HH1 < LL1),CLOSE,OPEN,COLORRED,0);
DRAWLINE((HH1 < LL1),HIGH,(HH1 < LL1),LOW,COLORRED);
STICKLINE((HH1 > LL1),CLOSE,OPEN,COLORGREEN,0);
DRAWLINE((HH1 > LL1),HIGH,(HH1 > LL1),LOW,COLORGREEN);
DRAWNUMBER(ISLASTBAR&&HH1 < LL1,LL,LL,0,COLORCYAN),ALIGN0;
DRAWNUMBER(ISLASTBAR&&HH1 > LL1,HH,HH,0,COLORCYAN),ALIGN0;

二:
N1=125,N2=5,N3=20
HX:=HHV(HIGH,3);
LX:=LLV(LOW,3);
H1:=IFELSE(HXCLOSE&&(HHV(OPEN,0)-CLOSE)>0,REF(HX,4),0);
L1:=IFELSE(LX>REF(LX,1)&&LX>REF(LX,3)&&LX>REF(LX,5)&&HX>REF(HX,1)&&HX>REF(HX,2)&&HX>REF(HX,4)&&OPEN0,REF(LX,4),0);
H2:=VALUEWHEN(H1>0,H1);
L2:=VALUEWHEN(L1>0,L1);
K1:=IFELSE(CLOSE>H2,-3,IFELSE(CLOSE
K2:=VALUEWHEN(K1<>0,K1);
G:=IFELSE(K2=1,H2,L2);
G1:=VALUEWHEN(ISLASTBAR,G);
DRAWNUMBER(LX>0,G1,G1,0,COLORCYAN);
TMP:=K2;
W1:=K2;
W2:=OPEN-CLOSE;
HT:=IFELSE(OPEN>CLOSE,OPEN,CLOSE);
LT:=IFELSE(OPEN
DRAWLINE(W1=1,HIGH,W1=1,HT,COLORCYAN);
DRAWLINE(W1=1,LOW,W1=1,LT,COLORCYAN);
DRAWLINE(W1=-3,HIGH,W1=-3,HT,COLORRED);
DRAWLINE(W1=-3,LOW,W1=-3,LT,COLORRED);
STICKLINE(W1>0,OPEN,CLOSE,COLORCYAN,1);
STICKLINE(W1<=0,OPEN,CLOSE,COLORRED,1);
STICKLINE(W2>0&&W1<=0,OPEN,CLOSE,COLORRED,0);
STICKLINE(W2>0&&W1>0,OPEN,CLOSE,COLORCYAN,0);
DRAWLINE(TMP=1&&REF(TMP,1)=1,G,TMP=1&&REF(TMP,1)=1,REF(G,1),COLORCYAN);
DRAWLINE(TMP=-3&&REF(TMP,1)=-3,G,TMP=-3&&REF(TMP,1)=-3,REF(G,1),COLORRED);
DRAWSL(K2=1,G,0,1,0,COLORCYAN);
DRAWSL(K2=-3,G,0,1,0,COLORRED);
DRAWTEXT(CROSS(TMP,0),HX,'卖');
DRAWTEXT(CROSS(0,TMP),LX,'买');
MA55:=MA(CLOSE,55);
DRAWTEXT(CROSS(TMP,0)&&CLOSE<=MA55,HX,'卖↓');
DRAWTEXT(CROSS(0,TMP)&&CLOSE>=MA55,LX,'买↑');

付费偷看设置
发送
1条回答
文华解答
1楼 · 09-15 21:41.采纳回答
一:
HH:=HHV(HIGH,10);
LL:=LLV(LOW,10);
HH1:=BARSLAST((HH > REF(HH,1)));
LL1:=BARSLAST((LL < REF(LL,1)));
PARTLINE((HH1 < LL1),LL,COLORRED);
PARTLINE((HH1 > LL1),HH,COLORCYAN);
STICKLINE((HH1 < LL1),CLOSE,OPEN,COLORRED,0);
DRAWLINE((HH1 < LL1),HIGH,(HH1 < LL1),LOW,COLORRED);
STICKLINE((HH1 > LL1),CLOSE,OPEN,COLORGREEN,0);
DRAWLINE((HH1 > LL1),HIGH,(HH1 > LL1),LOW,COLORGREEN);
DRAWNUMBER(ISLASTBAR&&HH1 < LL1,LL,LL,0,COLORCYAN),ALIGN0;
DRAWNUMBER(ISLASTBAR&&HH1 > LL1,HH,HH,0,COLORCYAN),ALIGN0;
CROSS(HH1,LL)||CROSSDOWN(HH1,LL),SPARK;


二:
N1=125,N2=5,N3=20
HX:=HHV(HIGH,3);
LX:=LLV(LOW,3);
H1:=IFELSE(HXCLOSE&&(HHV(OPEN,0)-CLOSE)>0,REF(HX,4),0);
L1:=IFELSE(LX>REF(LX,1)&&LX>REF(LX,3)&&LX>REF(LX,5)&&HX>REF(HX,1)&&HX>REF(HX,2)&&HX>REF(HX,4)&&OPEN0,REF(LX,4),0);
H2:=VALUEWHEN(H1>0,H1);
L2:=VALUEWHEN(L1>0,L1);
K1:=IFELSE(CLOSE>H2,-3,IFELSE(CLOSE
K2:=VALUEWHEN(K1<>0,K1);
G:=IFELSE(K2=1,H2,L2);
G1:=VALUEWHEN(ISLASTBAR,G);
DRAWNUMBER(LX>0,G1,G1,0,COLORCYAN);
TMP:=K2;
W1:=K2;
W2:=OPEN-CLOSE;
HT:=IFELSE(OPEN>CLOSE,OPEN,CLOSE);
LT:=IFELSE(OPEN
DRAWLINE(W1=1,HIGH,W1=1,HT,COLORCYAN);
DRAWLINE(W1=1,LOW,W1=1,LT,COLORCYAN);
DRAWLINE(W1=-3,HIGH,W1=-3,HT,COLORRED);
DRAWLINE(W1=-3,LOW,W1=-3,LT,COLORRED);
STICKLINE(W1>0,OPEN,CLOSE,COLORCYAN,1);
STICKLINE(W1<=0,OPEN,CLOSE,COLORRED,1);
STICKLINE(W2>0&&W1<=0,OPEN,CLOSE,COLORRED,0);
STICKLINE(W2>0&&W1>0,OPEN,CLOSE,COLORCYAN,0);
DRAWLINE(TMP=1&&REF(TMP,1)=1,G,TMP=1&&REF(TMP,1)=1,REF(G,1),COLORCYAN);
DRAWLINE(TMP=-3&&REF(TMP,1)=-3,G,TMP=-3&&REF(TMP,1)=-3,REF(G,1),COLORRED);
DRAWSL(K2=1,G,0,1,0,COLORCYAN);
DRAWSL(K2=-3,G,0,1,0,COLORRED);
DRAWTEXT(CROSS(TMP,0),HX,'卖');
DRAWTEXT(CROSS(0,TMP),LX,'买');
MA55:=MA(CLOSE,55);
DRAWTEXT(CROSS(TMP,0)&&CLOSE<=MA55,HX,'卖↓');
DRAWTEXT(CROSS(0,TMP)&&CLOSE>=MA55,LX,'买↑');
CROSS(TMP,0)||CROSSDOWN(TMP,0),SPARK;

相关问答

    Copyright © 2020 自动化交易