[求助]请写个公式?

08-06 22:11发布

EMA55:EMA(C,55),COLORRED,LINETHICK4;
EMA165:EMA(C,165),COLORYELLOW,LINETHICK4;

连续五根k线,每根k线的开盘价都低于前一根k线的开盘价且每根k线的收盘价都低于前一根k线的收盘价的时候在第五根k线上画哭脸。
反之画笑脸。
然后k线数值大于55日ema数值,且满足笑脸时标记声音a。
当k线数值小于55日ema数值,且哭脸时标记声音b。

EMA55:EMA(C,55),COLORRED,LINETHICK4;
EMA165:EMA(C,165),COLORYELLOW,LINETHICK4;
连续五根k线,每根k线的开盘价都低于前一根k线的开盘价且每根k线的收盘价都低于前一根k线的收盘价的时候在第五根k线上画哭脸。
反之画笑脸。
然后k线数值大于55日ema数值,且满足笑脸时标记声音a。
当k线数值小于55日ema数值,且哭脸时标记声音b。
付费偷看设置
发送
9条回答
无知无畏
2楼-- · 08-06 23:19
DRAWICON(CROSS(EMA13>EMA21&&EMA21>EMA34,0.5),H,92);
DRAWICON(CROSS(EMA13
老师可以把标记笑脸哭脸的公式写成这个模式的吗,我想修改的时候好改改
3楼-- · 08-06 23:39
参考:
EMA55:EMA(C,55),COLORRED,LINETHICK4;
EMA165:EMA(C,165),COLORYELLOW,LINETHICK4;
DRAWICON(EVERY(ODRAWICON(EVERY(O>REF(O,1)&&C>REF(C,1),5),H,1);
C>EMA55&&EVERY(O>REF(O,1)&&C>REF(C,1),5),SOUND('A');
C
无语无文
4楼-- · 08-06 23:58
谢谢老师了,麻烦老师,要是将开盘价和收盘价改为最大值,最小值呢?还是和上面同样的方法?
再次谢谢!能再写一个吗?
文华自动化
5楼-- · 08-07 00:18
参考:
EMA55:EMA(C,55),COLORRED,LINETHICK4;
EMA165:EMA(C,165),COLORYELLOW,LINETHICK4;
DRAWICON(EVERY(HDRAWICON(EVERY(H>REF(H,1)&&L>REF(L,1),5),H,1);
C>EMA55&&EVERY(H>REF(H,1)&&L>REF(L,1),5),SOUND('A');
C
文华菜鸟
6楼-- · 08-07 00:38
连续五根k线,每根k线的最高值都低于前一根最高值k线的最高值且每根k线的最低值都低于前一根k线的最低值的时候在第五根k线上画哭脸。
反之画笑脸
无知无畏
7楼-- · 08-07 00:58
参考5楼回复
Copyright © 2020 自动化交易