老师请求编辑一下指标

2天前发布

 HH:HHV(H,50);
LL:LLV(L,50);
DRAWICON(CROSS(C,HH) ,L-5,'ICO4');
DRAWICON(CROSSDOWN(C,LL) ,H+5,'ICO5');

老师这是海龟源码指标,且输出收盘价上穿HH显示红箭头指标,收盘价下穿LL显示绿箭头指标,问题是当遇到连续的红箭头那就不是我要的信号了,求老师做出只显示第一次红箭头指标同理相反也是显示第一次绿箭头指标
 

 HH:HHV(H,50);
LL:LLV(L,50);
DRAWICON(CROSS(C,HH) ,L-5,'ICO4');
DRAWICON(CROSSDOWN(C,LL) ,H+5,'ICO5');

老师这是海龟源码指标,且输出收盘价上穿HH显示红箭头指标,收盘价下穿LL显示绿箭头指标,问题是当遇到连续的红箭头那就不是我要的信号了,求老师做出只显示第一次红箭头指标同理相反也是显示第一次绿箭头指标
 
付费偷看设置
发送
3条回答
无知无畏
2楼-- · 2天前
 您的意思是红绿箭头交替绘制?
天涯爱文华
3楼-- · 2天前
 桃桃老师怪我没有说清楚是三十个交易日内第一次出现红箭头
文华菜鸟
4楼-- · 2天前
  HH:HV(H,50);
LL:LV(L,50);
DRAWICON(CROSS(COUNT(CROSS(C,HH) ,30),0.5),L-5,'ICO4');
DRAWICON(CROSS(COUNT(CROSSDOWN(C,LL) ,30),0.5) ,H+5,'ICO5');