每天盈利一点点,世界依然如故

    金字塔 固定止损止盈模块-后台 指标公式源码 [复制链接]

    autojiaoyi.com 发表于 ・1041 次阅读 源码与公式 查看全部 使用道具 举报 回复

    金字塔 固定止损止盈模块-后台 指标公式源码

    //该模型为简单示范模型,用户需根据自己交易经验,修改完善后再实际应用!!!
    //该模型运行于后台程序化模式
    
    ZH1:'1000';
    PZ1:'IF00';
    
    //条件判断
    MA5:MA(CLOSE,5);
    MA10:MA(CLOSE,10);
    CONDBUY:=CROSS(MA5,MA10);
    CONDSELL:=CROSS(MA10,MA5);
    
    //开仓和平仓
    TBUY(CONDBUY AND TBUYHOLDINGEX( ZH1,PZ1 ,0 )<10,1,LMT,CLOSE,0,ZH1,PZ1 );
    TSELL(CONDSELL,TBUYHOLDINGEX( ZH1,PZ1 ,0 ),MKT,0,ZH1,PZ1);
    
    
    //固定止损止盈模块部分*******************************
    //固定止盈条件判断
    ZYCOND:DYNAINFO(  7)-TAVGENTERPRICEEX2(ZH1 ,PZ1 ,0)>=50*MINDIFF;
    //固定止损条件判断
    ZSCOND:TAVGENTERPRICEEX2(ZH1 ,PZ1 ,0)-DYNAINFO(  7)>=20*MINDIFF;
    //固定止损止盈下单
    TSELL(ZYCOND,TBUYHOLDINGEX( ZH1,PZ1 ,0 ),MKT,0,ZH1,PZ1);
    TSELL(ZSCOND,TBUYHOLDINGEX( ZH1,PZ1 ,0 ),MKT,0,ZH1,PZ1);
    //**********************************************

    全部评论/0 条

    本版积分规则

    发布新内容
    加入收藏 我要分享
    分享到论坛或者博客

    复制
    热门指标策略
    快速回复 返回顶部 返回列表