每天盈利一点点,世界依然如故

    金字塔 RSI相对强弱指标交易 指标公式源码 [复制链接]

    autojiaoyi.com 发表于 ・1305 次阅读 源码与公式 查看全部 使用道具 举报 回复

    金字塔 RSI相对强弱指标交易 指标公式源码

    //该模型为简单示范模型,用户需根据自己交易经验,修改完善后再实际应用!!!
    
    //适用模式:“走完一根K线以后”
    //若用户模式选为“固定时间间隔”,请将"交易条件"中的CLOSE改为OPEN,避免信号闪烁。
    
    //中间变量
    LC:=REF(CLOSE,1);
    RSI:=SMA(MAX(CLOSE-LC,0),6,1)/
    SMA(ABS(CLOSE-LC),6,1)*100; 
    
    手数:=1;
    //交易条件
    
    开多平空条件:=CROSS(RSI,20);//开多平空条件
    开空平多条件:=CROSS(80,RSI);//开空平多条件
    
    //交易系统
    平空:SELLSHORT(开多平空条件,手数,MARKET);
    平多:SELL(开空平多条件,手数,MARKET);
    开多:BUY(开多平空条件,手数,MARKET);
    开空:BUYSHORT(开空平多条件,手数,MARKET);
    
    当前持仓:HOLDING,COLORGRAY,LINETHICK0;
    当前资产:ASSET,NOAXIS,COLORGRAY;
    
    //注意交易系统先开后平的原则

    全部评论/0 条

    本版积分规则

    发布新内容
    加入收藏 我要分享
    分享到论坛或者博客

    复制
    热门指标策略
    快速回复 返回顶部 返回列表