每天盈利一点点,世界依然如故

    wh6/wh7/wh8 macd 趋势划线源码:上升红色,下降绿色 [复制链接]

    autojiaoyi.com 发表于 ・1121 次阅读 赢顺 wh6 查看全部 使用道具 举报 回复

    wh6/wh7/wh8 macd 趋势划线源码:上升红色,下降绿色

    macd.JPG MACD 指标趋势线条件:
    下降绿色线:
    1、DIFF<0
    2、画最后一次满足条件的线
    3、DIFF 大于 0 之后的最高价,与小于0 之后的最低价连线
    上升红色线:
    1、DIFF.0
    2、画最后一次满足条件的线
    3、DIFF 小于 0 之后的最低价,与大于0 之后的最高价连线

    源码如下:
    DIFF := EMA(CLOSE,12) - EMA(CLOSE,26);
    DEA  := EMA(DIFF,9);
    MACD:=2*(DIFF-DEA),COLORSTICK;
    S:CROSSDOWN(DIFF,0),NODRAW;
    J:CROSS(DIFF,0),NODRAW;
    DRAWLINE3(DIFF<0&&ISLASTBAR,LLV(L,BARSLAST(S)+1),
    LLVBARS(L,BARSLAST(S)+1),1,REF(HHV(H,BARSLAST(J)+1),BARSLAST(S)+1),BARSLAST(S)+REF(  HHVBARS(H,BARSLAST(J)+1),BARSLAST(S)+1)+1,0),COLORLIGHTGREEN;
    DRAWLINE3(DIFF>0&&ISLASTBAR,HHV(H,BARSLAST(J)+1),
    HHVBARS(H,BARSLAST(J)+1),1,REF(LLV(L,BARSLAST(S)+1),BARSLAST(J)+1),BARSLAST(J)+REF(  LLVBARS(L,BARSLAST(S)+1),BARSLAST(J)+1)+1,0),COLORLIGHTRED;

    全部评论/0 条

    本版积分规则

    发布新内容
    加入收藏 我要分享
    分享到论坛或者博客

    复制
    热门指标策略
    快速回复 返回顶部 返回列表