请做一个自动交易系统

    苦行僧 发表于 2020-06-30 20:16 ・808次浏览 1条跟帖 赢智 wh8 回复

    请做一个自动交易系统:当RSI 指标上穿80数值时,待回调后第一个KDJ金叉时买多单,反之当RSI 指标下穿20数值时,待回调后第一个KDJ死叉时买空单。
    20点止盈40点止损,如果没有到止盈止损位出多和空信号都不开新单,待止盈止损后出新多空单才开新单!谢谢

    文华财经 沙发

    RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
    K:=SMA(RSV,3,1);
    D:=SMA(K,3,1);
    J:=3*K-2*D;
    LC := REF(CLOSE,1);
    RSI1:SMA(MAX(CLOSE-LC,0),7,1)/SMA(ABS(CLOSE-LC),7,1)*100;
    RSI2:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100;
    Q:=BARSLAST(RSI1>80);
    W:=BARSLAST(RSI1<20);
    Q<W&&CROSS(K,J)&&SUM(CROSS(K,J),BARSLAST(RSI1<80))=1,BK;
    Q>W&&CROSSDOWN(K,J)&&SUM(CROSSDOWN(K,J),BARSLAST(RSI1>20))=1,SK;
    AUTOFILTER;
    C>=BKPRICE+20*MINPRICE||C<=BKPRICE-40*MINPRICE,SP;
    C>=SKPRICE+40*MINPRICE||C<=SKPRICE-20*MINPRICE,BP;
    
    回复

    本版积分规则

    发布新内容
    请关注微信公众号,获取最新指标公式
    加入收藏 我要分享
    分享到论坛或者博客

    复制
    热门指标策略
    快速回复 返回顶部 返回列表