请将通达信“分时买卖点”改成文华指标

    东方不败 发表于 2020-06-20 20:10 ・1017次浏览 1条跟帖 赢顺 wh6 回复

    请将通达信“分时买卖点”改成文华指标 分时图上用
    最好出现买卖点有预警声音
    MA30:=EMA(CLOSE,30);
    强弱:EMA(CLOSE,900);
    STICKLINE((MA30>强弱),MA30,强弱,1,0),COLOR0000FF;
    STICKLINE((MA30<强弱),MA30,强弱,1,0),COLOR00FF00;
    H1:=MAX(DYNAINFO(3),DYNAINFO(5));
    L1:=MIN(DYNAINFO(3),DYNAINFO(6));
    P1:=H1-L1;
    阻力:L1+P1*7/8,COLOR00DD00;
    支撑:L1+P1*0.5/8,COLOR00DD00;
    现价:CLOSE,COLORWHITE,LINETHICK1;
    STICKLINE(CROSS(支撑,现价),支撑,阻力,1,0),COLORYELLOW;
    DRAWTEXT(LONGCROSS(支撑,现价,2),支撑*1.001,'★B'),COLORYELLOW;{吸}
    DRAWTEXT(LONGCROSS(现价,阻力,2),现价,'★'),COLORRED;{抛};
    

    文华财经 沙发

    分时图主要用来查看行情走势,加载指标做技术分析需要在K线图实现
    
    分时图实际上是1分钟收盘价的连线
    K线主图,右键-》技术分析-》K线形态-》选择CLOSE线,就是分时图的效果,再加载下面指标就可以了
    
    MA30:=EMA(CLOSE,30);
    强弱:EMA(CLOSE,900);
    
    STICKLINE1((MA30>强弱),MA30,强弱,1,0),COLOR0000FF;
    STICKLINE1((MA30<强弱),MA30,强弱,1,0),COLOR00FF00;
    
    DYNAINFO3:=GETPRICE('YCLOSE');
    H1:=MAX(DYNAINFO3,H);
    L1:=MIN(DYNAINFO3,L);
    P1:=H1-L1;
    阻力:L1+P1*7/8,COLOR00DD00;
    支撑:L1+P1*0.5/8,COLOR00DD00;
    现价:CLOSE,COLORWHITE,LINETHICK1;
    
    STICKLINE1(CROSS(支撑,现价),支撑,阻力,1,0),COLORYELLOW;
    
    DRAWTEXT(LONGCROSS(支撑,现价,2),支撑*1.001,'★B'),COLORYELLOW;
    DRAWTEXT(LONGCROSS(现价,阻力,2),现价,'★'),COLORRED;
    LONGCROSS(支撑,现价,2)||LONGCROSS(现价,阻力,2),SOUND('A');
    回复

    本版积分规则

    发布新内容
    请关注微信公众号,获取最新指标公式
    加入收藏 我要分享
    分享到论坛或者博客

    复制
    热门指标策略
    快速回复 返回顶部 返回列表