在15分钟周期引用1小时周期的均线

    无敌期货 发表于 2020-06-20 13:58 ・584次浏览 1条跟帖 赢智 wh8 回复

    想要在15分钟引用1小时周期均线指标,结果显示引用指标不存在,应该怎么引用呢?
    jml7GJEGxT8iql8v.jpg
    不是先建立要引用在指标,然后代入吗,模型语句如下:
    MULTSIG(0,0,5,0);
    MA35:MA(CLOSE,35);
    //35移动平均线TR:=MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));
    //真实波幅ATR:=MA(TR,26);
    //求26个周期内真实波幅的简单移动平均MA36:=MA(C,36);
    
    
    #IMPORT [HOUR,1,MA36] AS V1C1:=V1.MA36;
    MTC..SIGVOL(1)*2;
    L>MA(C,35)&&COUNT(L>MA(C,35),BARSLASTCOUNT(BKVOL+SKVOL=0))>=2&&NOT(BARSSP<2)&&NOT(BARSBP<2)&&C<YSETTLE*1.05&&ISTIMETOKLINEEND(30),BK(1);
    //2根K线的最低价大于35均线(但这两根K线不包括卖平信号的K线),做多,下单TC手H<MA(C,35)&&COUNT(H<MA(C,35),BARSLASTCOUNT(BKVOL+SKVOL=0))>=2&&NOT(BARSBP<2)&&NOT(BARSSP<2)&&C>YSETTLE*0.95&&ISTIMETOKLINEEND(30),SK(1);
    //2根K线的最高价小于35均线(但这两根K线不包括买平信号的K线),做空,下单TC手BKB:=IF(COUNTSIG(BK,1)>0,0,BARSBK);
    SKB:=IF(COUNTSIG(SK,1)>0,0,BARSSK);
    C<=BKPRICE-1.1*REF(ATR,BKB),SP(BKVOL);
    C>=SKPRICE+1.1*REF(ATR,SKB),BP(SKVOL);
    C<=BKPRICE-1.1*ATR&&COUNTSIG(BK,1)=1,SP(BKVOL);
    C>=SKPRICE+1.1*ATR&&COUNTSIG(SK,1)=1,BP(SKVOL);
    EXIST(BKHIGH-BKPRICE>=1.1*REF(ATR,BKB),BKB+1)&&C-BKPRICE<=0*ATR&&EXIST(BKHIGH-BKPRICE>=2.1*REF(ATR,BKB),BKB+1)=0,SP(BKVOL);
    EXIST(SKPRICE-SKLOW>=1.1*REF(ATR,SKB),SKB+1)&&SKPRICE-C<=0*ATR&&EXIST(SKPRICE-SKLOW>=2.1*REF(ATR,SKB),SKB+1)=0,BP(SKVOL);
    EXIST(BKHIGH-BKPRICE>=2.2*REF(ATR,BKB),BKB+1)&&C-BKPRICE<=1.1*REF(ATR,BKB)&&EXIST(BKHIGH-BKPRICE>=3.2*REF(ATR,BKB),BKB+1)=0,SP(BKVOL);
    EXIST(SKPRICE-SKLOW>=2.2*REF(ATR,SKB),SKB+1)&&SKPRICE-C<=1.1*REF(ATR,SKB)&&EXIST(SKPRICE-SKLOW>=3.2*REF(ATR,SKB),SKB+1)=0,BP(SKVOL);
    EXIST(BKHIGH-BKPRICE>=3.3*REF(ATR,BKB),BKB+1)&&C<=BKHIGH-0.2*(BKHIGH-BKPRICE),SP(BKVOL);
    EXIST(SKPRICE-SKLOW>=3.3*REF(ATR,SKB),SKB+1)&&C>=SKLOW+0.2*(SKPRICE-SKLOW),BP(SKVOL);
        

    文华财经 沙发

    下面指标这部分,是需要单独建立一个模型,保存模型名称为MA36
    
    该模型是不需要加载到K线图的
    MA35:MA(CLOSE,35);//35移动平均线
    TR:=MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));//真实波幅
    ATR:=MA(TR,26);//求26个周期内真实波幅的简单移动平均
    MA36:=MA(C,36);
    回复

    本版积分规则

    发布新内容
    请关注微信公众号,获取最新指标公式
    加入收藏 我要分享
    分享到论坛或者博客

    复制
    热门指标策略
    快速回复 返回顶部 返回列表