请将下列软件中上面变色线上涨改为黄色,下跌蓝色

    无敌期货 发表于 2020-06-18 12:26 ・904次浏览 1条跟帖 赢顺 wh6 回复

    请将下列软件中上面变色线上涨改为黄色,下跌蓝色;源码如下:
    LONG:=26;
    SHORT:=12;
    M:=9;
    OBV:=MA(SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0)/25000,1);
    DIFF : EMA(OBV,12) - EMA(OBV,26);
    BBDIFF:=DIFF-REF(DIFF,1);
    DEA : EMA(DIFF,9);
    BBDEA:=DEA-REF(DEA,1);
    MACD : 2*(DIFF-DEA), COLORSTICK;
    柱: 2*(DIFF-DEA);
    BB柱:=柱-REF(柱,1);
    IF(BBDIFF>0,DIFF,NULL),COLORFF00CC,LINETHICK2;
    IF(BBDIFF<=0,DIFF,NULL),COLOR9999FF,LINETHICK2;
    IF(BBDEA>0,DEA,NULL),COLORFF6600,LINETHICK2;
    IF(BBDEA<=0,DEA,NULL),COLOR33FF00,LINETHICK2;
    IF(BB柱>0,柱,NULL),COLORFF00CC,LINETHICK2;
    IF(BB柱<=0,柱,NULL),COLOR9999FF,LINETHICK2;
    DIFF速率:BBDIFF*100,NODRAW;
    DEA速率:BBDEA*100,NODRAW;
    柱速率:BB柱*100,NODRAW;
    FILLRGN(DIFF>DEA,DIFF,DEA,COLORRED);
    FILLRGN(DIFF<DEA,DIFF,DEA,COLORGREEN);
       
    

    文华财经 沙发

    修改,参考:
    LONG:=26;
    SHORT:=12;
    M:=9;
    OBV:=MA(SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0)/25000,1);
    DIFF : EMA(OBV,12) - EMA(OBV,26);
    BBDIFF:=DIFF-REF(DIFF,1);
    DEA : EMA(DIFF,9);
    BBDEA:=DEA-REF(DEA,1);
    MACD : 2*(DIFF-DEA), COLORSTICK;
    柱: 2*(DIFF-DEA);
    BB柱:=柱-REF(柱,1);
    IF(BBDIFF>0,DIFF,NULL),COLORFF00CC,LINETHICK2;
    IF(BBDIFF<=0,DIFF,NULL),COLOR9999FF,LINETHICK2;
    IF(BBDEA>0,DEA,NULL),COLORFF6600,LINETHICK2;
    IF(BBDEA<=0,DEA,NULL),COLOR33FF00,LINETHICK2;
    IF(BB柱>0,柱,NULL),COLORFF00CC,LINETHICK2;
    IF(BB柱<=0,柱,NULL),COLOR9999FF,LINETHICK2;
    DIFF速率:BBDIFF*100,NODRAW;
    DEA速率:BBDEA*100,NODRAW;
    柱速率:BB柱*100,NODRAW;
    FILLRGN(DIFF>DEA,DIFF,DEA,COLORRED);
    FILLRGN(DIFF<DEA,DIFF,DEA,COLORGREEN);
    DRAWCOLORLINE(柱>REF(柱,1),柱,COLORYELLOW,COLORBLUE),LINETHICK2;
    
    回复

    本版积分规则

    发布新内容
    请关注微信公众号,获取最新指标公式
    加入收藏 我要分享
    分享到论坛或者博客

    复制
    热门指标策略
    快速回复 返回顶部 返回列表