文华 wh8 日内经典策略:菲阿里四价 指标公式

    autojiaoyi.com 发表于 2020-06-17 20:36 ・813次浏览 0条跟帖 赢智 wh8 回复

    菲阿里四价

    昨天高点,昨天低点,昨天收盘,今天开盘,可并称为菲阿里四价,它是由日本期货冠军菲阿里实盘采用的主要突破交易的参照系,此外,因菲阿里主观心智交易的模式,决定了其在实际交易中,还大量结合应用了“阻溢线”的概念,即我们通常所说的压力、支撑线。



    策略原理:
    依据昨日高点、昨日低点、昨日收盘、今日开盘确定开闭盘条件

    1)趋势交易策略

    上下轨确定:
    上轨=昨日高点;
    下轨=昨日低点;
    买卖信号:1、当价格突破上轨,买入开仓;2、当价格跌穿下轨,卖出开仓。

    策略源码:

    NN1:=BARSLAST(DATE<>REF(DATE,1))+1;
    NNC1:=COUNTSIG(BK,NN1)+COUNTSIG(SK,NN1)+COUNTSIG(BPK,NN1)+COUNTSIG(SPK,NN1);
    //表示当日的开仓次数
    ZG:REF(HHV(H,NN1),NN1);
    ZD:REF(LLV(L,NN1),NN1);//分别表示昨日最高价格 昨日最低价格
    CROSSUP(C,ZG)&&NNC1<5,BK;
    CROSSDOWN(C,ZD)&&NNC1<5,SK;
    //表示突破昨日最高价做多 突破昨日最低价格做空(当日做多做空最大5次)
    C<=BKPRICE-10*MINPRICE,SP;
    C>=SKPRICE+10*MINPRICE,BP;//表示开仓价格的10个点位止损平仓
    C>=BKPRICE+40*MINPRICE,SP;
    C<=SKPRICE-40*MINPRICE,BP;//表示开仓价格的40点止盈
    ISLASTKLINE,CLOSEOUT;//尾盘清仓
    AUTOFILTER;
    //以上模型仅仅用来示范演示使用,依此入市,风险自负。

    2)震荡交易策略

    买卖信号:
    开盘下跌,今日开盘价<昨日收盘价,当价格突破开盘价时,做多。
    开盘上涨,今日开盘价>昨日收盘价,当价格跌破收盘价时,做空;

    策略源码:
    NN1:=BARSLAST(DATE<>REF(DATE,1))+1;
    NNC1:=COUNTSIG(BK,NN1)+COUNTSIG(SK,NN1)+COUNTSIG(BPK,NN1)+COUNTSIG(SPK,NN1);
    //表示当日的开仓次数
    ZC:REF(C,NN1);//昨日收盘价
    JK:VALUEWHEN(NN1=1,O);//今日开盘价
    JK<ZC&&CROSSUP(C,JK)&&NNC1<5,BK;
    JK>ZC&&CROSSDOWN(C,ZC)&&NNC1<5,SK;
    //开盘下跌,价格突破开盘价时做多  ;  开盘上涨,价格跌破收盘价时做空(当日做多做空最大5次)
    C<=BKPRICE-10*MINPRICE,SP;
    C>=SKPRICE+10*MINPRICE,BP;//表示开仓价格的10个点位止损平仓
    C>=BKPRICE+40*MINPRICE,SP;
    C<=SKPRICE-40*MINPRICE,BP;//表示开仓价格的40点止盈
    ISLASTKLINE,CLOSEOUT;//尾盘清仓
    AUTOFILTER;
    //以上模型仅仅用来示范演示使用,依此入市,风险自负。

    本版积分规则

    发布新内容
    请关注微信公众号,获取最新指标公式
    加入收藏 我要分享
    分享到论坛或者博客

    复制
    热门指标策略
    快速回复 返回顶部 返回列表