麻烦在下面公式中用MA20日线过滤竖线

    菜鸟 发表于 2020-06-16 21:04 ・839次浏览 1条跟帖 赢顺 wh6 回复

    在下面公式中用MA20日线过滤竖线;红色竖线的开盘价在20日线之下就不要红色竖线,绿色竖线的开盘价在20日线之上就不要绿色竖线
    N:=5;
    //ZIGZAG(H,5,1),SETSTYLECOLOR(LINETHICK3,COLORYELLOW);
    DRAWCOLORLINE(ZIGZAG(H,5,1)>=REF(ZIGZAG(H,5,1),1),ZIGZAG(H,5,1),COLORRED,COLORGREEN),LINETHICK3;
    A1:=BACKSET(ISLASTBAR,PEAKBARS(H,5,1,1)+1);
    A2:=A1>REF(A1,1);
    B1:=BACKSET(ISLASTBAR,PEAKBARS(H,5,2,1)+1);
    B2:=B1>REF(B1,1);
    C1:=BACKSET(ISLASTBAR,TROUGHBARS(H,5,1,1)+1);
    C2:=C1>REF(C1,1);
    VERTLINE1(A2);
    VERTLINE1(B2);
    //VERTLINE(C2);
    Z1:=BARSLAST(A2);
    Y1:=BARSLAST(B2);
    Z2:REF(Z1,DATACOUNT);
    Y2:REF(Y1,DATACOUNT);
    Y3:=Y2-Y1+1;
    SZ:=Y2-Z2;
    SZ1:INTPART(Y2-SZ*0.382);
    SZ2:INTPART(Y2-SZ*0.618);
    SZ3:INTPART(Y2-SZ*1.382);
    SZ4:INTPART(Y2-SZ*1.618);
    VERTLINE1(Y3=SZ1+1);
    VERTLINE1(Y3=SZ2+1);
    VERTLINE1(Y3=SZ3+1);
    VERTLINE1(Y3=SZ4+1);
    HH1:=IFELSE(H<REF(H,1)&&REF(H,1)<REF(H,2),REF(H,2),0);
    LL1:=IFELSE(L>REF(L,1)&&REF(L,1)>REF(L,2),REF(L,2),0);
    HH2:=VALUEWHEN(HH1>0,HH1);
    LL2:=VALUEWHEN(LL1>0,LL1);
    K1:=IFELSE(CLOSE>HH2,-3,IFELSE(CLOSE<LL2,1,0));
    K2:=VALUEWHEN(K1<>0,K1);
    G:=IFELSE(K2=1,HH2,LL2);
    G1:=VALUEWHEN(ISLASTBAR,G);
    DRAWNUMBER(L>0,G1,G1,0,COLORCYAN);
    W1:=K2;
    W2:=OPEN-CLOSE;
    HT:=IFELSE(OPEN>CLOSE,OPEN,CLOSE);
    VERTLINE( K2=-3&&REF(K2=1,1)&&ZIGZAG(H,5,1)>=REF(ZIGZAG(H,5,1),1),COLORRED),LINETHICK2;
    VERTLINE( K2=1&&REF(K2=-3,1)&&ZIGZAG(H,5,1)<REF(ZIGZAG(H,5,1),1),COLORGREEN),LINETHICK2;  
    

    文华财经 沙发

    改写参考:
    N:=5;
    MA20:MA(C,20);
    //ZIGZAG(H,5,1),SETSTYLECOLOR(LINETHICK3,COLORYELLOW);
    DRAWCOLORLINE(ZIGZAG(H,5,1)>=REF(ZIGZAG(H,5,1),1),ZIGZAG(H,5,1),COLORRED,COLORGREEN),LINETHICK3;
    A1:=BACKSET(ISLASTBAR,PEAKBARS(H,5,1,1)+1);
    A2:=A1>REF(A1,1);
    B1:=BACKSET(ISLASTBAR,PEAKBARS(H,5,2,1)+1);
    B2:=B1>REF(B1,1);
    C1:=BACKSET(ISLASTBAR,TROUGHBARS(H,5,1,1)+1);
    C2:=C1>REF(C1,1);
    VERTLINE1(A2);
    VERTLINE1(B2);
    //VERTLINE(C2);
    Z1:=BARSLAST(A2);
    Y1:=BARSLAST(B2);
    Z2:REF(Z1,DATACOUNT);
    Y2:REF(Y1,DATACOUNT);
    Y3:=Y2-Y1+1;
    SZ:=Y2-Z2;
    SZ1:INTPART(Y2-SZ*0.382);
    SZ2:INTPART(Y2-SZ*0.618);
    SZ3:INTPART(Y2-SZ*1.382);
    SZ4:INTPART(Y2-SZ*1.618);
    VERTLINE1(Y3=SZ1+1);
    VERTLINE1(Y3=SZ2+1);
    VERTLINE1(Y3=SZ3+1);
    VERTLINE1(Y3=SZ4+1);
    HH1:=IFELSE(H<REF(H,1)&&REF(H,1)<REF(H,2),REF(H,2),0);
    LL1:=IFELSE(L>REF(L,1)&&REF(L,1)>REF(L,2),REF(L,2),0);
    HH2:=VALUEWHEN(HH1>0,HH1);
    LL2:=VALUEWHEN(LL1>0,LL1);
    K1:=IFELSE(CLOSE>HH2,-3,IFELSE(CLOSE<LL2,1,0));
    K2:=VALUEWHEN(K1<>0,K1);
    G:=IFELSE(K2=1,HH2,LL2);
    G1:=VALUEWHEN(ISLASTBAR,G);
    DRAWNUMBER(L>0,G1,G1,0,COLORCYAN);
    W1:=K2;
    W2:=OPEN-CLOSE;
    HT:=IFELSE(OPEN>CLOSE,OPEN,CLOSE);
    VERTLINE( K2=-3&&REF(K2=1,1)&&ZIGZAG(H,5,1)>=REF(ZIGZAG(H,5,1),1)&&O>=MA20,COLORRED),LINETHICK2;
    VERTLINE( K2=1&&REF(K2=-3,1)&&ZIGZAG(H,5,1)<REF(ZIGZAG(H,5,1),1)&&O<=MA20,COLORGREEN),LINETHICK2;
    
    
    
    回复

    本版积分规则

    发布新内容
    请关注微信公众号,获取最新指标公式
    加入收藏 我要分享
    分享到论坛或者博客

    复制
    热门指标策略
    快速回复 返回顶部 返回列表