修改指标周期

    苦行僧 发表于 2020-06-13 21:00 ・639次浏览 1条跟帖 赢顺 wh6 回复

    跪求老师们帮我把这个指标修改一下周期和改成主图!为:13.89.160.均线。
    
    CURRBARSCOUNT:=DATACOUNT-BARPOS+1;
     RSVA2:=100*(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9));
      VAR11:=SMA(RSVA1,3,1);
      顶底线:=VAR51-VAR21+50;
      VAR3:=HHV(HIGH,21);
      趋势:=100-EMA(0.191*REF(VAR4,1)+0.809*VAR4,1);
      顶线:90,COLORWHITE;
      当前安全度:100-EMA(0.191*REF(VAR4,1)+0.809*VAR4,1),CIRCLEDOT,LINETHICK2,COLORRED;
     DRAWTEXT(CURRBARSCOUNT=6,15,'安区'),COLORWHITE;
     DRAWTEXT(CURRBARSCOUNT=6,85,'风险区'),COLORWHITE;
      {强拉升}  Y2:=SMA(ABS(L-REF(L,1)),17,1);
      Q:=-(EMA(IF(L<=Y1,Y2/Y3,-3),1));
      强拉升: IF(CROSS(Q,0),1,0),COLORYELLOW;
      STICKLINE1(CROSS(Q1,-24),20,0,4,0),COLORMAGENTA;
      VAR22:=EMA(EMA(EMA((2*CLOSE+HIGH+LOW)/4,4),4),4);
      地:=( MA((VAR22-REF(VAR22,1))/REF(VAR22,1)*100,1));
      STICKLINE1(地>天 AND 地<0,10,0,1,0),COLORRED;
      VAR2B:=SMA(VAR1B,9,1)+100;
      VAR4B:=SMA(VAR3B,3,1);
      VAR6B:=VAR5B-VAR2B;
      VAR2Q:=REF(LOW,1);
      VAR4Q:=EMA(IF(CLOSE*1.3,VAR3Q*10,VAR3Q/10),3);
      VAR6Q:=HHV(VAR4Q,30);
      VAR8Q:=EMA(IF(LOW<=VAR5Q,(VAR4Q+VAR6Q*2)/2,0),3)/999*VAR7Q;
      RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
     STICKLINE1(REF(趋势1,1)< 趋势1, 趋势1,REF(趋势1,1),2.8,0),COLOR000055;
      STICKLINE1(REF(趋势1,1)< 趋势1, 趋势1,REF(趋势1,1),1.2,0),COLOR000099;
      STICKLINE1(REF(趋势1,1)> 趋势1, 趋势1,REF(趋势1,1),3.5,0),COLOR003300;
      STICKLINE1(REF(趋势1,1)> 趋势1, 趋势1,REF(趋势1,1),2.0,0),COLOR007700;
      STICKLINE1(REF(趋势1,1)> 趋势1, 趋势1,REF(趋势1,1),0.4,0),COLOR00DD00;
      STICKLINE1( 逃顶,逃顶,10,3.5,0),COLORFF5500;
     STICKLINE1( 逃顶,逃顶,20,1.5,0),COLORFFAA00;
      STICKLINE1( 逃顶,逃顶,30,0.1,0),COLORFFFF00;
     D2:=EMA(D1,6);
      BBUY:=CROSS(D2,D3);
      DRAWICON(BBUY,20,1);
      DRAWICON(CROSS(82,VARR1),10,15);
      A1:20;
     A3:90;
     BB:=RSI>80;
     STICKLINE1(AA,A1,A1*0.9,3,0),COLORYELLOW;
     STICKLINE1(BB,A2,A2*1.03,3,0),COLORGREEN;
     STICKLINE1(CC,A3,A3*1.05,3,0),COLORFFFFFF;
     DRAWICON(CC,A3*1.09,6);
     XA1:=EMA(CLOSE,8);
     X31:=IF(((SG < REF(SG,1)) OR X30),1,0);
     STICKLINE1(全仓出击,40,0,3,0),COLORFF00FF;
     DRAWTEXT((全仓出击 >= 48),48,'大胆杀入');
     P:=55;
     M1:=3;
     神:=EMA(财,M1),COLORGREEN,LINETHICK1;
     FILLRGN(财<神,财,神,RGB(0,100,50));
    

    文华财经 沙发

    看了一下,您1楼指标是根据副图指标编制的,编写的样式也是符合副图坐标的
    因为主图和副图是独立的坐标,所以加载到主图上会有压缩,这样也看不出具体的效果,所以不建议这么使用

    回复

    本版积分规则

    发布新内容
    请关注微信公众号,获取最新指标公式
    加入收藏 我要分享
    分享到论坛或者博客

    复制
    热门指标策略
    快速回复 返回顶部 返回列表