请转个m指标

    苦行僧 发表于 2020-06-10 21:21 ・772次浏览 1条跟帖 赢顺 wh6 回复

    {副图MACD,参数N1:0,1,1,缺省为1}
    {DRAWGBK(C>0, RGB(0,108,108),RGB(88,0,0),0,ཇ',0);}
    SHORT:=12;
    LONG:=26;
    MID:=9;
    DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
    DEA:EMA(DIF,MID);
    MACD:(DIF-DEA)*2,COLORSTICK;
    DRAWICON(REF(DIF,1)<REF(DIF,2) AND DIF>REF(DIF,1) AND DIF<0 AND DIF<DEA,DIF*1.1,1),COLORRED;
    HJ_2:=BARSLAST(REF(MACD,1)<0 AND MACD>0);
    HJ_3:=LLVBARS(MACD,HJ_2+20);
    HJ_4:=IF(HJ_3>HJ_2,REF(MACD,HJ_3),0);
    HJ_5:=MACD<0 AND MACD>HJ_4 AND LOW=LLV(LOW,HJ_2+20) AND HJ_4<0;
    HJ_6:=REF(HJ_5,1)=1 AND MACD>REF(MACD,1) AND REF(DIF,HJ_3)<0 AND MACD<0;
    底背:DRAWLINE(HJ_4=HJ_3,MACD,HJ_6,MACD,0),COLORRED,DOTLINE;
    DRAWICON(HJ_6,MACD*1.2,9);
    HJ_7:=HHVBARS(MACD,HJ_2+20);
    HJ_8:=IF(HJ_7>HJ_2,REF(MACD,HJ_7),0);
    HJ_9:=MACD>0 AND MACD<HJ_8 AND HIGH=HHV(HIGH,HJ_2+20) AND HJ_8>0;
    HJ_10:=REF(HJ_9,1)=1 AND MACD>REF(MACD,1) AND REF(DIF,HJ_7)>0;
    顶背:DRAWLINE(HJ_8=HJ_7,MACD,HJ_10,MACD,0),COLOR1D7300,DOTLINE;
    DRAWICON(HJ_10,MACD*1.2,15);
    HJ_11:=CLOSE/MA(CLOSE,40)*100<78;
    HJ_12:=CLOSE/MA(CLOSE,60)*100<74;
        
    

    autojiaoyi.com 沙发

     参考:
    
    //{副图MACD,参数N1:0,1,1,缺省为1}
    DRAWGBK(C>0, RGB(0,108,108),RGB(88,0,0),0);
    SHORT:=12;
    LONG:=26;
    MID:=9;
    DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
    DEA:EMA(DIF,MID);
    MACD:(DIF-DEA)*2,COLORSTICK;
    DRAWICON(REF(DIF,1)<REF(DIF,2) AND DIF>REF(DIF,1) AND DIF<0 AND DIF<DEA,DIF*1.1,1),COLORRED;
    HJ_2:=BARSLAST(REF(MACD,1)<0 AND MACD>0);
    HJ_3:=LLVBARS(MACD,HJ_2+20);
    HJ_4:=IF(HJ_3>HJ_2,REF(MACD,HJ_3),0);
    HJ_5:=MACD<0 AND MACD>HJ_4 AND LOW=LLV(LOW,HJ_2+20) AND HJ_4<0;
    HJ_6:=REF(HJ_5,1)=1 AND MACD>REF(MACD,1) AND REF(DIF,HJ_3)<0 AND MACD<0;
    DRAWLINE(HJ_4=HJ_3,MACD,HJ_6,MACD,0),COLORRED,DOT;
    DRAWICON(HJ_6,MACD*1.2,9);
    HJ_7:=HHVBARS(MACD,HJ_2+20);
    HJ_8:=IF(HJ_7>HJ_2,REF(MACD,HJ_7),0);
    HJ_9:=MACD>0 AND MACD<HJ_8 AND HIGH=HHV(HIGH,HJ_2+20) AND HJ_8>0;
    HJ_10:=REF(HJ_9,1)=1 AND MACD>REF(MACD,1) AND REF(DIF,HJ_7)>0;
    DRAWLINE(HJ_8=HJ_7,MACD,HJ_10,MACD,0),COLOR1D7300,DOT;
    DRAWICON(HJ_10,MACD*1.2,15);
    HJ_11:=CLOSE/MA(CLOSE,40)*100<78;
    HJ_12:=CLOSE/MA(CLOSE,60)*100<74;
    
    回复

    本版积分规则

    发布新内容
    请关注微信公众号,获取最新指标公式
    加入收藏 我要分享
    分享到论坛或者博客

    复制
    热门指标策略
    快速回复 返回顶部 返回列表