WH6指标编写的问题

    无敌期货 发表于 2020-06-16 21:01 ・804次浏览 1条跟帖 赢顺 wh6 回复

    HH:REF(HHV(C,30),1),COLORRED;
    LL:REF(LLV(C,30),1),COLORGREEN;
    C>HH,ICON(1,'ICO158');
    C<LL,ICON(1,'ICO157');
    我想在指标里设置一个买进卖出的图标,但是使用上面的指标买进之后 会出现连续的图标 只要是突破前高 就会出现我想只在第一次突破的时候出现请问这样可以设置吗 需要怎样修改呢?
    HH:REF(HHV(C,30),1),COLORRED;
    LL:REF(LLV(C,30),1),COLORGREEN;
    CROSS(C>HH,0.5),ICON(1,'ICO158');
    CROSS(C<LL.0.5),ICON(1,'ICO157');
    之前咨询的WH6指标编写问题 并没有解决问题。还是会出现多个买入卖出图标,另外加入0.5是什么设置
    谢谢    
    

    文华财经 沙发

    这么看下:
    
    HH:REF(HHV(C,30),1),COLORRED;
    LL:REF(LLV(C,30),1),COLORGREEN;
    CROSS(C,HH)&&COUNT(CROSS(C,HH),BARSLAST(CROSSDOWN(C,LL))+1)=1,ICON(1,'ICO158');
    CROSSDOWN(C,LL)&&COUNT(CROSSDOWN(C,LL),BARSLAST(CROSS(C,HH))+1)=1,ICON(1,'ICO157');
    
    CROSS(条件,0.5) 表示第一次满足条件的位置
    
    可以使用DRAWCOLORKLINE函数实现K线变色,参考:
    
    HH:REF(HHV(C,30),1),COLORRED;
    LL:REF(LLV(C,30),1),COLORGREEN;
    CROSS(C,HH)&&COUNT(CROSS(C,HH),BARSLAST(CROSSDOWN(C,LL))+1)=1,ICON(1,'ICO158');
    CROSSDOWN(C,LL)&&COUNT(CROSSDOWN(C,LL),BARSLAST(CROSS(C,HH))+1)=1,ICON(1,'ICO157');
    DRAWCOLORKLINE(BARSLAST(C>HH)+1<BARSLAST(C<LL)+1,COLORRED,0);
    DRAWCOLORKLINE(BARSLAST(C>HH)+1>BARSLAST(C<LL)+1,COLORGREEN,0);
    
    回复

    本版积分规则

    发布新内容
    请关注微信公众号,获取最新指标公式
    加入收藏 我要分享
    分享到论坛或者博客

    复制
    热门指标策略
    快速回复 返回顶部 返回列表