任意两种指标金叉做多

    东方不败 发表于 2020-06-10 21:32 ・850次浏览 1条跟帖 赢智 wh8 回复

    麻烦给写个程序
    形成金叉的那一时间才算,金叉死叉区域不算

    autojiaoyi.com 沙发

    参考:
    
    MA5:MA(C,5);
    MA10:MA(C,10);
    DIFF:EMA(CLOSE,12) - EMA(CLOSE,26);
    DEA:EMA(DIFF,9);
    MACD:2*(DIFF-DEA),COLORSTICK;
    RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;//收盘价与N周期最低值做差,N周期最高值与N周期最低值做差,两差之间做比值。
    K:SMA(RSV,3,1);//RSV的移动平均值
    D:SMA(K,3,1);//K的移动平均值
    LC := REF(CLOSE,1);//前一周期收盘价
    RSI1:SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;//当根K线收盘价与前一周期收盘价做差,在该差值与0之间取最大值,做N1周期移动平均。收盘价与前一周期收盘价做差值,取该差值的N1周期移动平均值,两平均值之间做比值。
    RSI2:SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
    
    JC1:=CROSS(MA5,MA10);
    SC1:=CROSSDOWN(MA5,MA10);
    JC2:=CROSS(DIFF,DEA);
    SC2:=CROSSDOWN(DIFF,DEA);
    JC3:=CROSS(K,D);
    SC3:=CROSSDOWN(K,D);
    JC4:=CROSS(RSI1,RSI2);
    SC4:=CROSSDOWN(RSI1,RSI2);
    
    JC1+JC2+JC3+JC4>=2,BK;
    SC1+SC2+SC3+SC4>=2,SK;
    回复

    本版积分规则

    发布新内容
    请关注微信公众号,获取最新指标公式
    加入收藏 我要分享
    分享到论坛或者博客

    复制
    热门指标策略
    快速回复 返回顶部 返回列表