分形前后一根K线画顶、底横线 [复制链接]

    autojiaoyi.com 源码学习 查看全部 使用道具 举报 回复

    01.png
    TMP:=OPEN-CLOSE;
    DRAWLINE(TMP>0.00001,HIGH,TMP>0.00001,OPEN,COLORCYAN);
    DRAWLINE(TMP>0.00001,LOW,TMP>0.00001,CLOSE,COLORCYAN);
    DRAWLINE(TMP<-0.00001,HIGH,TMP<-0.00001,CLOSE,COLORRED);
    DRAWLINE(TMP<-0.00001,LOW,TMP<-0.00001,OPEN,COLORRED);
    DRAWLINE(ABS(TMP)<0.00001,LOW,ABS(TMP)<0.00001,OPEN,COLORWHITE);
    DRAWLINE(ABS(TMP)<0.00001,HIGH,ABS(TMP)<0.00001,OPEN,COLORWHITE);
    STICKLINE(TMP>0,OPEN,CLOSE,COLORCYAN,0);
    STICKLINE(TMP<=0,OPEN,CLOSE,COLORRED,1);
    HO:= HIGH >REF( HIGH,1)  && HIGH >=REFX(HIGH,1) && IFELSE(HIGH =REFX(HIGH,1), HIGH >REFX(HIGH,2), HIGH >REFX(HIGH,1));
    FXH:=CROSS(HO,0.9);
    HH:=REF(HIGH,BARSLAST(FXH));
    LO:= LOW <REF(LOW,1)  && LOW <=REFX(LOW,1) && IFELSE(LOW =REFX(LOW,1), LOW <REFX(LOW,2), LOW <REFX(LOW,1));
    FXL:=CROSS(LO,0.9);
    LL:=REF(LOW,BARSLAST(FXL));
    STICKLINE(CLOSE,HH,HH-0.00001,COLORMAGENTA,0);
    STICKLINE(CLOSE,LL,LL-0.00001,COLORGREEN,0);

    全部评论/0 条

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    0关注

    1粉丝

    453作品

    发布主题
    加入收藏 我要分享

    分享到微信

    打开微信扫一扫即可将网页分享至微信

    分享到论坛或者博客

    复制
    作者的其他作品查看全部
    快速回复 返回顶部 返回列表