多空加权均值,显示多空均线 [复制链接]

    autojiaoyi.com 源码学习 查看全部 使用道具 举报 回复

    08.jpg
    A:=(3*C+L+O+H)/6;//3倍收盘价与最高价、最低价、开盘价之和的均值。
    B:(20*A+19*REF(A,1)+18*REF(A,2) +17*REF(A,3)+16*REF(A,4) +15*REF(A,5)+14*REF(A,6) +13*REF(A,7)+12*REF(A,8) +11*REF(A,9)+10*REF(A,10) +9*REF(A,11)+8*REF(A,12) +7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;
    //对A值做加权均值计算。
    D:MA(B,10);//对B值做10周期平均计算。
    MA1:MA(C,40),LINETHICK3,COLORYELLOW;
    PARTLINE1(MA1>REF(MA1,1) AND C>MA1,MA1),LINETHICK4,COLORRED;
    PARTLINE1(MA1<REF(MA1,1) AND C<MA1,MA1),LINETHICK4,COLORGREEN;

    全部评论/0 条

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    0关注

    1粉丝

    453作品

    发布主题
    加入收藏 我要分享

    分享到微信

    打开微信扫一扫即可将网页分享至微信

    分享到论坛或者博客

    复制
    作者的其他作品查看全部
    快速回复 返回顶部 返回列表