多空锤子线以及看涨吞没源码 [复制链接]

    autojiaoyi.com 源码学习 查看全部 使用道具 举报 回复

    ST:=MAX(C,O)-MIN(C,O); 
    SY:=H-MAX(C,O);
    XY:=MIN(C,O)-L;
    K1:=SY<=ST&&XY>=ST*2&&NOT(C=O);
    K2:=REF(ISUP&&C<>O,1)&&ISDOWN&&MAX(C,O)>=REF(MAX(C,O),1)&&MIN(C,O)<=REF(MIN(C,O),1)&&ST>REF(ST,1);
    KT:=REF(K1||K2,1);
    KTEXT(KT,-1,L-3,1,COLORMAGENTA,'空'),VALIGN0;
    
    T1:SY<=ST&&XY>=ST*2 &&NOT(C=O&&H-O>0&&O-L>0);
    T2:=REF(ISDOWN&&C<>O,1)&&ISUP&&MAX(C,O)>=REF(MAX(C,O),1)&&MIN(C,O)<=REF(MIN(C,O),1)&&ST>REF(ST,1);
    TT:=REF(T1||T2,1);
    KTEXT(TT,-1,L-3,1,COLORRED,'多'),VALIGN0;

    全部评论/0 条

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    0关注

    1粉丝

    453作品

    发布主题
    加入收藏 我要分享

    分享到微信

    打开微信扫一扫即可将网页分享至微信

    分享到论坛或者博客

    复制
    作者的其他作品查看全部
    快速回复 返回顶部 返回列表