MACD 顶/底背离 源码 [复制链接]

    autojiaoyi.com 源码学习 查看全部 使用道具 举报 回复

    20171016033217698.png
    DIFF:EMA(C,12) - EMA(CLOSE,26);
    DEA:EMA(DIFF,9);
    MACD:2*(DIFF-DEA),NODRAW;
    2*(DIFF-DEA),COLORSTICK;//DIFF减DEA的2倍画柱状线
    
    UPCOND:=CROSS(DIFF,DEA);
    DOWNCOND:=CROSSDOWN(DIFF,DEA);
    END_N1:=SUMBARS(DOWNCOND,1);
    RANGE_N1:=REF(SUMBARS(UPCOND,1),END_N1);
    END_N2:=SUMBARS(DOWNCOND,2);
    
    HH1:=REF(HV(H,RANGE_N1),END_N1-1);
    HH2:=REF(HV(H,RANGE_N1),END_N2-1);
    MACD1:=REF(HV(MACD,RANGE_N1),END_N1-1);
    MACD2:=REF(HV(MACD,RANGE_N1),END_N2-1);
    
    顶背离:=CROSS(0,MACD) && HH1>HH2 && MACD1<MACD2;
    DRAWTEXT(顶背离,MACD,'顶背离');
    
    END_M1:=SUMBARS(UPCOND,1);
    RANGE_M1:=REF(SUMBARS(DOWNCOND,1),END_M1);
    END_M2:=SUMBARS(UPCOND,2);
    LL1:=REF(LV(L,RANGE_M1),END_M1-1);
    LL2:=REF(LV(L,RANGE_M1),END_M2-1);
    MACD3:=REF(LV(MACD,RANGE_M1),END_M1-1);
    MACD4:=REF(LV(MACD,RANGE_M1),END_M2-1);
    
    底背离:=CROSS(MACD,0) && LL1<LL2 && MACD3>MACD4;
    DRAWTEXT(底背离,MACD,'底背离');

    全部评论/1 条

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    蔡英红 沙发

    好用,刚试下下,很清楚 回复

    0关注

    1粉丝

    453作品

    发布主题
    加入收藏 我要分享

    分享到微信

    打开微信扫一扫即可将网页分享至微信

    分享到论坛或者博客

    复制
    作者的其他作品查看全部
    快速回复 返回顶部 返回列表